summaryrefslogtreecommitdiff
path: root/meson.build
diff options
context:
space:
mode:
authorBastien Nocera <hadess@hadess.net>2021-10-28 17:40:54 +0200
committerBastien Nocera <hadess@hadess.net>2021-10-28 18:00:46 +0200
commit3d3d1c13793212c89752170c8403a84156df31fa (patch)
tree514ca9aef46a3805dfe70ce902f076ea9f4af7c3 /meson.build
parentbb7901cbdc91dc2495d8856f3e5929b378b878de (diff)
downloadgnome-bluetooth-3d3d1c13793212c89752170c8403a84156df31fa.tar.gz
sendto: Make sendto optional
Diffstat (limited to 'meson.build')
-rw-r--r--meson.build5
1 files changed, 4 insertions, 1 deletions
diff --git a/meson.build b/meson.build
index d62cd9bc..15257d3f 100644
--- a/meson.build
+++ b/meson.build
@@ -107,7 +107,9 @@ m_dep = cc.find_library('m')
subdir('icons')
subdir('lib')
-subdir('sendto')
+if get_option('sendto')
+ subdir('sendto')
+endif
if enable_gtk_doc
subdir('docs/reference/libgnome-bluetooth')
@@ -132,6 +134,7 @@ meson.add_install_script(
summary({'Documentation': enable_gtk_doc,
'Introspection': enable_gir,
+ 'Send-to': get_option('sendto'),
'Run gtk-update-icon-cache': get_option('icon_update')},
section: 'General')