summaryrefslogtreecommitdiff
path: root/meson.build
diff options
context:
space:
mode:
authorBastien Nocera <hadess@hadess.net>2021-10-28 17:38:37 +0200
committerBastien Nocera <hadess@hadess.net>2021-10-28 18:00:46 +0200
commitbb7901cbdc91dc2495d8856f3e5929b378b878de (patch)
treef4ef3a1be0838f086fb409e34983d45af4f92848 /meson.build
parent8f7b52b664b9f0da03192ffa45e15fb4fd27a979 (diff)
downloadgnome-bluetooth-bb7901cbdc91dc2495d8856f3e5929b378b878de.tar.gz
build: Use summary() to print build summary
Diffstat (limited to 'meson.build')
-rw-r--r--meson.build13
1 files changed, 5 insertions, 8 deletions
diff --git a/meson.build b/meson.build
index 27dcb3c8..d62cd9bc 100644
--- a/meson.build
+++ b/meson.build
@@ -3,7 +3,7 @@ project(
version: '42.alpha',
license: 'GPL2+',
default_options: 'buildtype=debugoptimized',
- meson_version: '>= 0.49.0',
+ meson_version: '>= 0.53.0',
)
gnomebt_version = meson.project_version()
@@ -130,13 +130,10 @@ meson.add_install_script(
gnomebt_datadir,
)
-output = '\nConfigure summary:\n\n'
-output += ' Compiler....................: ' + cc.get_id() + '\n\n'
-output += ' Compiler Flags..............: ' + ' '.join(compiler_flags) + '\n'
-output += ' Prefix......................: ' + gnomebt_prefix + '\n'
-output += ' Documentation...............: ' + enable_gtk_doc.to_string() + '\n'
-output += ' GObject-Introspection.......: ' + enable_gir.to_string()
-message(output)
+summary({'Documentation': enable_gtk_doc,
+ 'Introspection': enable_gir,
+ 'Run gtk-update-icon-cache': get_option('icon_update')},
+ section: 'General')
meson.add_dist_script(
find_program('check-news.sh').path(),