summaryrefslogtreecommitdiff
path: root/gio/tests/meson.build
diff options
context:
space:
mode:
authorMarco Trevisan (Treviño) <mail@3v1n0.net>2022-10-19 21:34:48 +0200
committerMarco Trevisan (Treviño) <mail@3v1n0.net>2022-10-31 14:08:31 +0100
commit54a9e797fea796cd8597d4bd0de6f3c82d080640 (patch)
tree03d543236948e7f7b3c38cef1e93f07cb08584be /gio/tests/meson.build
parentb9e085537d8c72373bd40d31edd592bfe9d172aa (diff)
downloadglib-54a9e797fea796cd8597d4bd0de6f3c82d080640.tar.gz
ci: Mark failing windows tests as can-fail and do not ignore test failures
Diffstat (limited to 'gio/tests/meson.build')
-rw-r--r--gio/tests/meson.build5
1 files changed, 4 insertions, 1 deletions
diff --git a/gio/tests/meson.build b/gio/tests/meson.build
index f000907d8..f6d6a020a 100644
--- a/gio/tests/meson.build
+++ b/gio/tests/meson.build
@@ -69,7 +69,9 @@ gio_tests = {
'giomodule' : {},
'gsubprocess' : {},
'g-file' : {},
- 'g-file-info' : {},
+ 'g-file-info' : {
+ 'can_fail' : host_system == 'windows',
+ },
'g-icon' : {},
'gdbus-addresses' : {},
'gdbus-message' : {},
@@ -78,6 +80,7 @@ gio_tests = {
'install_rpath' : installed_tests_execdir,
# FIXME: https://gitlab.gnome.org/GNOME/glib/-/issues/1392
'should_fail' : host_system == 'darwin',
+ 'can_fail' : host_system == 'windows',
},
'inet-address' : {},
'io-stream' : {},