summaryrefslogtreecommitdiff
path: root/gio/tests/meson.build
diff options
context:
space:
mode:
authorMarco Trevisan (Treviño) <mail@3v1n0.net>2022-10-20 00:51:34 +0200
committerMarco Trevisan (Treviño) <mail@3v1n0.net>2022-10-31 14:08:31 +0100
commitb9e085537d8c72373bd40d31edd592bfe9d172aa (patch)
tree44bf9304ce772a614ee03ee85874f45557cd34b5 /gio/tests/meson.build
parent914bb06ab43f38e9edc6df2bd95fe26f39bdf7e8 (diff)
downloadglib-b9e085537d8c72373bd40d31edd592bfe9d172aa.tar.gz
meson: Expose library build type as global variables
Given that it can be computed using an error-prone strings comparisons it is better to provide a variable everywhere, so that we don't have the risk of comparing values that are always false.
Diffstat (limited to 'gio/tests/meson.build')
-rw-r--r--gio/tests/meson.build6
1 files changed, 3 insertions, 3 deletions
diff --git a/gio/tests/meson.build b/gio/tests/meson.build
index c894f12e0..f000907d8 100644
--- a/gio/tests/meson.build
+++ b/gio/tests/meson.build
@@ -223,7 +223,7 @@ if host_machine.system() != 'windows'
}
# LD_PRELOAD modules don't work so well with AddressSanitizer
- if have_rtld_next and get_option('default_library') != 'static' and get_option('b_sanitize') == 'none'
+ if have_rtld_next and glib_build_shared and get_option('b_sanitize') == 'none'
gio_tests += {
'gsocketclient-slow' : {
'depends' : [
@@ -652,7 +652,7 @@ if meson.can_run_host_binaries()
compiler_type = '--compiler=@0@'.format(cc.get_id())
- if get_option('default_library') != 'static'
+ if glib_build_shared
plugin_resources_c = custom_target('plugin-resources.c',
input : 'test4.gresource.xml',
output : 'plugin-resources.c',
@@ -983,6 +983,6 @@ endif
subdir('services')
-if get_option('default_library') != 'static'
+if glib_build_shared
subdir('modules')
endif