summaryrefslogtreecommitdiff
path: root/setup.py
diff options
context:
space:
mode:
authorMonty Taylor <mordred@inaugust.com>2011-10-05 15:50:36 -0400
committerMonty Taylor <mordred@inaugust.com>2011-10-05 15:50:36 -0400
commitc43cec18577e44d1f5e95f40376a78cb39746df6 (patch)
tree56fd592e47391b5691a5ea104bdc52b3eb9446f7 /setup.py
parent0c21fa6cb38d2da4ee3e06f37af38d3fcedf68b8 (diff)
downloadgit-review-c43cec18577e44d1f5e95f40376a78cb39746df6.tar.gz
Fix manpage installation for setup.py install.
Change-Id: If9906cea283ada30d4901969c2b949086a9074b2
Diffstat (limited to 'setup.py')
-rwxr-xr-xsetup.py14
1 files changed, 12 insertions, 2 deletions
diff --git a/setup.py b/setup.py
index e18c99d..e37f671 100755
--- a/setup.py
+++ b/setup.py
@@ -14,8 +14,9 @@
# See the License for the specific language governing permissions and
# limitations under the License.
-from distutils.core import setup
+from setuptools import setup
from distutils.command.build import build
+from setuptools.command.bdist_egg import bdist_egg
from sphinx.setup_command import BuildDoc
import commands
@@ -33,12 +34,21 @@ class local_build_sphinx(BuildDoc):
BuildDoc.run(self)
cmdclass['build_sphinx'] = local_build_sphinx
+
class local_build(build):
def run(self):
build.run(self)
commands.getoutput("sphinx-build -b man -c doc doc/ build/sphinx/man")
cmdclass['build'] = local_build
+
+class local_bdist_egg(bdist_egg):
+ def run(self):
+ commands.getoutput("sphinx-build -b man -c doc doc/ build/sphinx/man")
+ bdist_egg.run(self)
+cmdclass['bdist_egg'] = local_bdist_egg
+
+
setup(
name='git-review',
version=version,
@@ -50,6 +60,6 @@ setup(
author_email='openstack@lists.launchpad.net',
url='http://www.openstack.org',
scripts=['git-review'],
- data_files=[('share/man/man1',['build/sphinx/man/git-review.1'])],
+ data_files=[('share/man/man1', ['build/sphinx/man/git-review.1'])],
cmdclass=cmdclass,
)