summaryrefslogtreecommitdiff
path: root/setup.py
diff options
context:
space:
mode:
authorMonty Taylor <mordred@inaugust.com>2011-10-05 00:15:26 -0400
committerMonty Taylor <mordred@inaugust.com>2011-10-05 00:20:36 -0400
commit0c21fa6cb38d2da4ee3e06f37af38d3fcedf68b8 (patch)
tree33bb34e18e0462b7e284aec403445302dec1291e /setup.py
parent08bd9cf1e8128427f68d73773bcd602ed19d567e (diff)
downloadgit-review-0c21fa6cb38d2da4ee3e06f37af38d3fcedf68b8.tar.gz
Install man pages.
Change-Id: I5458682a559f2202ba7a6c923b3b8b85c19f9cef
Diffstat (limited to 'setup.py')
-rwxr-xr-xsetup.py37
1 files changed, 17 insertions, 20 deletions
diff --git a/setup.py b/setup.py
index 46ad282..e18c99d 100755
--- a/setup.py
+++ b/setup.py
@@ -14,29 +14,30 @@
# See the License for the specific language governing permissions and
# limitations under the License.
-from setuptools import setup, find_packages
+from distutils.core import setup
+from distutils.command.build import build
+from sphinx.setup_command import BuildDoc
+import commands
# Please also change this in git-review when changing it.
version = '1.1'
cmdclass = {}
-# If Sphinx is installed on the box running setup.py,
-# enable setup.py to build the documentation, otherwise,
-# just ignore it
-try:
- from sphinx.setup_command import BuildDoc
- class local_BuildDoc(BuildDoc):
- def run(self):
- for builder in ['html', 'man']:
- self.builder = builder
- self.finalize_options()
- BuildDoc.run(self)
- cmdclass['build_sphinx'] = local_BuildDoc
+class local_build_sphinx(BuildDoc):
+ def run(self):
+ for builder in ['html', 'man']:
+ self.builder = builder
+ self.finalize_options()
+ BuildDoc.run(self)
+cmdclass['build_sphinx'] = local_build_sphinx
-except:
- pass
+class local_build(build):
+ def run(self):
+ build.run(self)
+ commands.getoutput("sphinx-build -b man -c doc doc/ build/sphinx/man")
+cmdclass['build'] = local_build
setup(
name='git-review',
@@ -48,11 +49,7 @@ setup(
author='OpenStack, LLC.',
author_email='openstack@lists.launchpad.net',
url='http://www.openstack.org',
- include_package_data=True,
- #packages=find_packages(exclude=['test', 'bin']),
scripts=['git-review'],
- zip_safe=False,
+ data_files=[('share/man/man1',['build/sphinx/man/git-review.1'])],
cmdclass=cmdclass,
- install_requires=['setuptools'],
- test_suite='nose.collector',
)