summaryrefslogtreecommitdiff
path: root/doc/Makefile.am
diff options
context:
space:
mode:
Diffstat (limited to 'doc/Makefile.am')
-rw-r--r--doc/Makefile.am9
1 files changed, 8 insertions, 1 deletions
diff --git a/doc/Makefile.am b/doc/Makefile.am
index 1dd67dc7..060d104e 100644
--- a/doc/Makefile.am
+++ b/doc/Makefile.am
@@ -19,11 +19,18 @@ AUTOMAKE_OPTIONS = foreign
SUBDIRS = . html
+if FLaC__HAS_DOXYGEN
FLAC.tag: Doxyfile
doxygen Doxyfile
rm -rf html/api
mv doxytmp/html html/api
rm -rf doxytmp
+else
+FLAC.tag:
+ echo "*** Warning: Doxygen not found; documentation will not be built."
+ touch $<
+ mkdir -p html/api
+endif
docdir = $(datadir)/doc/$(PACKAGE)-$(VERSION)
@@ -32,5 +39,5 @@ doc_DATA = \
EXTRA_DIST = Doxyfile Makefile.lite $(doc_DATA)
-clean-local:
+maintainer-clean-local:
rm -rf FLAC.tag html/api doxytmp