summaryrefslogtreecommitdiff
path: root/doc/Makefile.am
diff options
context:
space:
mode:
authorJosh Coalson <jcoalson@users.sourceforce.net>2003-01-10 04:38:44 +0000
committerJosh Coalson <jcoalson@users.sourceforce.net>2003-01-10 04:38:44 +0000
commit52afda911528bebccee6f951dee880eceea413d5 (patch)
treecbd2053f706c50db9d8051185e3e6837472bd625 /doc/Makefile.am
parent9caf4937e2f69c43a499401d4867a15d0458a89b (diff)
downloadflac-52afda911528bebccee6f951dee880eceea413d5.tar.gz
only clean doxygen-generated files with maintainer-clean; warn during build if doxygen is not available
Diffstat (limited to 'doc/Makefile.am')
-rw-r--r--doc/Makefile.am9
1 files changed, 8 insertions, 1 deletions
diff --git a/doc/Makefile.am b/doc/Makefile.am
index 1dd67dc7..060d104e 100644
--- a/doc/Makefile.am
+++ b/doc/Makefile.am
@@ -19,11 +19,18 @@ AUTOMAKE_OPTIONS = foreign
SUBDIRS = . html
+if FLaC__HAS_DOXYGEN
FLAC.tag: Doxyfile
doxygen Doxyfile
rm -rf html/api
mv doxytmp/html html/api
rm -rf doxytmp
+else
+FLAC.tag:
+ echo "*** Warning: Doxygen not found; documentation will not be built."
+ touch $<
+ mkdir -p html/api
+endif
docdir = $(datadir)/doc/$(PACKAGE)-$(VERSION)
@@ -32,5 +39,5 @@ doc_DATA = \
EXTRA_DIST = Doxyfile Makefile.lite $(doc_DATA)
-clean-local:
+maintainer-clean-local:
rm -rf FLAC.tag html/api doxytmp