summaryrefslogtreecommitdiff
path: root/configure.ac
diff options
context:
space:
mode:
authorEli Zaretskii <eliz@gnu.org>2023-03-06 17:31:57 +0200
committerEli Zaretskii <eliz@gnu.org>2023-03-06 17:31:57 +0200
commit8a8a994cfab0a7413caa0f0849063accadf81393 (patch)
tree2eee93fac27d630ddb7770442e8cd06be2568577 /configure.ac
parentde4277af009115ceba7fe920163c05c608ea9524 (diff)
downloademacs-8a8a994cfab0a7413caa0f0849063accadf81393.tar.gz
Revert "Fix configuration of webp libraries"
This reverts commit de4277af009115ceba7fe920163c05c608ea9524. It breaks WebP support at least on my system. There's no reason to require libwebpdecoder library to be installed, since we don't use the functions from it, at least not in libwebp 1.2.1.
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac3
1 files changed, 1 insertions, 2 deletions
diff --git a/configure.ac b/configure.ac
index 2787370fbff..bc7e61048c3 100644
--- a/configure.ac
+++ b/configure.ac
@@ -2803,8 +2803,7 @@ if test "${with_webp}" != "no"; then
|| test "${HAVE_W32}" = "yes" || test "${HAVE_NS}" = "yes" \
|| test "${HAVE_BE_APP}" = "yes" || test "${HAVE_PGTK}" = "yes"; then
WEBP_REQUIRED=0.6.0
- WEBP_MODULE="libwebpdemux >= $WEBP_REQUIRED \
- libwebpdecoder >= $WEBP_REQUIRED"
+ WEBP_MODULE="libwebpdemux >= $WEBP_REQUIRED"
EMACS_CHECK_MODULES([WEBP], [$WEBP_MODULE])
AC_SUBST([WEBP_CFLAGS])