summaryrefslogtreecommitdiff
path: root/configure.ac
diff options
context:
space:
mode:
authorPo Lu <luangruo@yahoo.com>2023-03-06 21:42:29 +0800
committerPo Lu <luangruo@yahoo.com>2023-03-06 21:42:29 +0800
commitde4277af009115ceba7fe920163c05c608ea9524 (patch)
tree140be3de1bc595c57646ea31ed0661452106853f /configure.ac
parent1c67e4f895faf895f3ff132261edcbe6d08bb91d (diff)
downloademacs-de4277af009115ceba7fe920163c05c608ea9524.tar.gz
Fix configuration of webp libraries
* configure.ac: Link with libwebpdecoder along with libwebpdemux. (bug#61988)
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac3
1 files changed, 2 insertions, 1 deletions
diff --git a/configure.ac b/configure.ac
index bc7e61048c3..2787370fbff 100644
--- a/configure.ac
+++ b/configure.ac
@@ -2803,7 +2803,8 @@ if test "${with_webp}" != "no"; then
|| test "${HAVE_W32}" = "yes" || test "${HAVE_NS}" = "yes" \
|| test "${HAVE_BE_APP}" = "yes" || test "${HAVE_PGTK}" = "yes"; then
WEBP_REQUIRED=0.6.0
- WEBP_MODULE="libwebpdemux >= $WEBP_REQUIRED"
+ WEBP_MODULE="libwebpdemux >= $WEBP_REQUIRED \
+ libwebpdecoder >= $WEBP_REQUIRED"
EMACS_CHECK_MODULES([WEBP], [$WEBP_MODULE])
AC_SUBST([WEBP_CFLAGS])