summaryrefslogtreecommitdiff
path: root/setup.py
diff options
context:
space:
mode:
Diffstat (limited to 'setup.py')
-rw-r--r--setup.py9
1 files changed, 6 insertions, 3 deletions
diff --git a/setup.py b/setup.py
index 4682451..b628f4a 100644
--- a/setup.py
+++ b/setup.py
@@ -26,9 +26,6 @@ requirements = [
'docker-pycreds >= 0.2.1'
]
-if sys.platform == 'win32':
- requirements.append('pypiwin32 >= 219')
-
extras_require = {
':python_version < "3.5"': 'backports.ssl_match_hostname >= 3.5',
# While not imported explicitly, the ipaddress module is required for
@@ -36,6 +33,12 @@ extras_require = {
# ServerAltname: https://pypi.python.org/pypi/backports.ssl_match_hostname
':python_version < "3.3"': 'ipaddress >= 1.0.16',
+ # win32 APIs if on Windows (required for npipe support)
+ # Python 3.6 is only compatible with v220 ; Python < 3.5 is not supported
+ # on v220 ; ALL versions are broken for v222 (as of 2018-01-26)
+ ':sys_platform == "win32" and python_version < "3.6"': 'pypiwin32==219',
+ ':sys_platform == "win32" and python_version >= "3.6"': 'pypiwin32==220',
+
# If using docker-py over TLS, highly recommend this option is
# pip-installed or pinned.