summaryrefslogtreecommitdiff
path: root/setup.py
diff options
context:
space:
mode:
authorJoffrey F <joffrey@docker.com>2018-01-26 12:52:03 -0800
committerJoffrey F <joffrey@docker.com>2018-01-26 13:44:31 -0800
commita5490ad0be6840961758d090f573ceb1ef0a5d96 (patch)
tree55c8e4d8fc46e09244535fa3660c8f7c9da445a4 /setup.py
parentba46201ca6990ae078caf8368322c646d01a8763 (diff)
downloaddocker-py-a5490ad0be6840961758d090f573ceb1ef0a5d96.tar.gz
Fix appveyor tests
Signed-off-by: Joffrey F <joffrey@docker.com>
Diffstat (limited to 'setup.py')
-rw-r--r--setup.py9
1 files changed, 6 insertions, 3 deletions
diff --git a/setup.py b/setup.py
index 4682451..b628f4a 100644
--- a/setup.py
+++ b/setup.py
@@ -26,9 +26,6 @@ requirements = [
'docker-pycreds >= 0.2.1'
]
-if sys.platform == 'win32':
- requirements.append('pypiwin32 >= 219')
-
extras_require = {
':python_version < "3.5"': 'backports.ssl_match_hostname >= 3.5',
# While not imported explicitly, the ipaddress module is required for
@@ -36,6 +33,12 @@ extras_require = {
# ServerAltname: https://pypi.python.org/pypi/backports.ssl_match_hostname
':python_version < "3.3"': 'ipaddress >= 1.0.16',
+ # win32 APIs if on Windows (required for npipe support)
+ # Python 3.6 is only compatible with v220 ; Python < 3.5 is not supported
+ # on v220 ; ALL versions are broken for v222 (as of 2018-01-26)
+ ':sys_platform == "win32" and python_version < "3.6"': 'pypiwin32==219',
+ ':sys_platform == "win32" and python_version >= "3.6"': 'pypiwin32==220',
+
# If using docker-py over TLS, highly recommend this option is
# pip-installed or pinned.