summaryrefslogtreecommitdiff
path: root/configure.ac
diff options
context:
space:
mode:
authorLars Wendler <polynomial-c@gentoo.org>2022-03-01 16:05:52 +0100
committerLars Wendler <polynomial-c@gentoo.org>2022-03-01 19:01:17 +0100
commit17c88a894499da64460a0ef76db1d8b88ceb9eeb (patch)
tree1607ad19fa106daf5b3d0c4b98575ef0cd7aa9cb /configure.ac
parent51e468d828785cbc7060678f6f257723ba11cd10 (diff)
downloaddbus-17c88a894499da64460a0ef76db1d8b88ceb9eeb.tar.gz
Emit an error when --with-x was given but no X11 libs were found
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac13
1 files changed, 7 insertions, 6 deletions
diff --git a/configure.ac b/configure.ac
index a51e7265..4420c6d3 100644
--- a/configure.ac
+++ b/configure.ac
@@ -1121,12 +1121,13 @@ else if test "x$with_x" != xno; then
have_x11=yes
DBUS_X_LIBS="$X_LIBS"
DBUS_X_CFLAGS="$X_CFLAGS"
- ],
- [ have_x11=no ])
-
- if test "x$have_x11" = xno; then
- AC_MSG_WARN([Couldn't found X11, tried with pkg-config.])
- fi
+ ], [
+ AS_IF([test "x$with_x" = xyes],
+ [AC_MSG_ERROR([Couldn't find X11, tried with pkg-config.])],
+ [AC_MSG_WARN([Couldn't find X11, tried with pkg-config.])]
+ )
+ have_x11=no
+ ])
else
AS_IF([test "x$enable_x11_autolaunch" = "xyes"], [
AC_MSG_ERROR([--enable-x11-autolaunch and --without-x are not compatible])