summaryrefslogtreecommitdiff
path: root/configure.ac
diff options
context:
space:
mode:
authorLars Wendler <polynomial-c@gentoo.org>2022-03-01 16:01:29 +0100
committerLars Wendler <polynomial-c@gentoo.org>2022-03-01 19:01:07 +0100
commit51e468d828785cbc7060678f6f257723ba11cd10 (patch)
treefd169406aafb956612d5b98dd8895a32075d106d /configure.ac
parent99cc28e0eb1a37233c0f7d3595175d1f331550e7 (diff)
downloaddbus-51e468d828785cbc7060678f6f257723ba11cd10.tar.gz
Move DBUS_X_* definitions into PKG_CHECK_MODULES block
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac10
1 files changed, 5 insertions, 5 deletions
diff --git a/configure.ac b/configure.ac
index 847e95fb..a51e7265 100644
--- a/configure.ac
+++ b/configure.ac
@@ -1117,15 +1117,15 @@ if test "x$dbus_win" = xyes; then
have_x11=no
else if test "x$with_x" != xno; then
PKG_CHECK_MODULES([X], [x11],
- [AC_DEFINE([HAVE_X11], [1], [Define to 1 if you have X11 library])],
+ [AC_DEFINE([HAVE_X11], [1], [Define to 1 if you have X11 library])
+ have_x11=yes
+ DBUS_X_LIBS="$X_LIBS"
+ DBUS_X_CFLAGS="$X_CFLAGS"
+ ],
[ have_x11=no ])
if test "x$have_x11" = xno; then
AC_MSG_WARN([Couldn't found X11, tried with pkg-config.])
- else
- have_x11=yes
- DBUS_X_LIBS="$X_LIBS"
- DBUS_X_CFLAGS="$X_CFLAGS"
fi
else
AS_IF([test "x$enable_x11_autolaunch" = "xyes"], [