summaryrefslogtreecommitdiff
path: root/CMakeLists.txt
diff options
context:
space:
mode:
authorJay Satiro <raysatiro@yahoo.com>2022-11-27 16:12:12 -0500
committerJay Satiro <raysatiro@yahoo.com>2022-12-07 14:41:09 -0500
commitfe3463eba7aebd0fc0d530c7cf81ef467b6cef9b (patch)
treea422f99f40d718d680e3da013f268979f8472cd0 /CMakeLists.txt
parent57d3477e77629430889a4159d2bf803892caf7c7 (diff)
downloadcurl-fe3463eba7aebd0fc0d530c7cf81ef467b6cef9b.tar.gz
build: assume errno.h is always available
- Remove errno.h detection from all build configurations. errno.h is a standard header according to C89. Closes https://github.com/curl/curl/pull/9986
Diffstat (limited to 'CMakeLists.txt')
-rw-r--r--CMakeLists.txt1
1 files changed, 0 insertions, 1 deletions
diff --git a/CMakeLists.txt b/CMakeLists.txt
index 9ecc57d11..b43520751 100644
--- a/CMakeLists.txt
+++ b/CMakeLists.txt
@@ -975,7 +975,6 @@ check_include_file_concat("sys/utime.h" HAVE_SYS_UTIME_H)
check_include_file_concat("sys/xattr.h" HAVE_SYS_XATTR_H)
check_include_file_concat("arpa/inet.h" HAVE_ARPA_INET_H)
check_include_file_concat("arpa/tftp.h" HAVE_ARPA_TFTP_H)
-check_include_file_concat("errno.h" HAVE_ERRNO_H)
check_include_file_concat("fcntl.h" HAVE_FCNTL_H)
check_include_file_concat("idn2.h" HAVE_IDN2_H)
check_include_file_concat("ifaddrs.h" HAVE_IFADDRS_H)