summaryrefslogtreecommitdiff
path: root/CMakeLists.txt
diff options
context:
space:
mode:
authorJay Satiro <raysatiro@yahoo.com>2022-11-27 16:03:39 -0500
committerJay Satiro <raysatiro@yahoo.com>2022-12-07 14:30:32 -0500
commit57d3477e77629430889a4159d2bf803892caf7c7 (patch)
tree535ee39190cfbe3ddf3eeb0cf940879bf62aa2fe /CMakeLists.txt
parent7865d09e4cddeb8faebadcbd24fb8f26cc9f81ec (diff)
downloadcurl-57d3477e77629430889a4159d2bf803892caf7c7.tar.gz
build: assume assert.h is always available
- Remove assert.h detection from all build configurations. assert.h is a standard header according to C89. I had proposed this several years ago as part of a larger change that was abandoned. Ref: https://github.com/curl/curl/issues/1237#issuecomment-277500720 Closes https://github.com/curl/curl/pull/9985
Diffstat (limited to 'CMakeLists.txt')
-rw-r--r--CMakeLists.txt1
1 files changed, 0 insertions, 1 deletions
diff --git a/CMakeLists.txt b/CMakeLists.txt
index 091746b46..9ecc57d11 100644
--- a/CMakeLists.txt
+++ b/CMakeLists.txt
@@ -975,7 +975,6 @@ check_include_file_concat("sys/utime.h" HAVE_SYS_UTIME_H)
check_include_file_concat("sys/xattr.h" HAVE_SYS_XATTR_H)
check_include_file_concat("arpa/inet.h" HAVE_ARPA_INET_H)
check_include_file_concat("arpa/tftp.h" HAVE_ARPA_TFTP_H)
-check_include_file_concat("assert.h" HAVE_ASSERT_H)
check_include_file_concat("errno.h" HAVE_ERRNO_H)
check_include_file_concat("fcntl.h" HAVE_FCNTL_H)
check_include_file_concat("idn2.h" HAVE_IDN2_H)