summaryrefslogtreecommitdiff
path: root/configure.ac
diff options
context:
space:
mode:
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac5
1 files changed, 4 insertions, 1 deletions
diff --git a/configure.ac b/configure.ac
index 1bcd41e484..d60f05251a 100644
--- a/configure.ac
+++ b/configure.ac
@@ -1993,11 +1993,14 @@ yes)
;;
esac
-# ICC needs -fp-model strict or floats behave badly
case "$CC" in
*icc*)
+ # ICC needs -fp-model strict or floats behave badly
CFLAGS_NODIST="$CFLAGS_NODIST -fp-model strict"
;;
+*xlc*)
+ CFLAGS_NODIST="$CFLAGS_NODIST -qalias=noansi -qmaxmem=-1"
+ ;;
esac
if test "$assertions" = 'true'; then