summaryrefslogtreecommitdiff
path: root/configure.ac
diff options
context:
space:
mode:
authorMiss Islington (bot) <31488909+miss-islington@users.noreply.github.com>2020-09-04 14:02:57 -0700
committerGitHub <noreply@github.com>2020-09-04 23:02:57 +0200
commitfb050d0d60f38dc9b6c30df1864020a92981be5b (patch)
tree86f092616a6db5f7f17376806c18d87c8d138ef8 /configure.ac
parent8f13ff959ae43fb6b8217845b2945779fe693b84 (diff)
downloadcpython-git-fb050d0d60f38dc9b6c30df1864020a92981be5b.tar.gz
bpo-41721: Add xlc options (GH-22097)
(cherry picked from commit 84a7917b4c9afec07575065cffa143b91fe98c14) Authored-by: Stefan Krah <skrah@bytereef.org>
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac5
1 files changed, 4 insertions, 1 deletions
diff --git a/configure.ac b/configure.ac
index 1bcd41e484..d60f05251a 100644
--- a/configure.ac
+++ b/configure.ac
@@ -1993,11 +1993,14 @@ yes)
;;
esac
-# ICC needs -fp-model strict or floats behave badly
case "$CC" in
*icc*)
+ # ICC needs -fp-model strict or floats behave badly
CFLAGS_NODIST="$CFLAGS_NODIST -fp-model strict"
;;
+*xlc*)
+ CFLAGS_NODIST="$CFLAGS_NODIST -qalias=noansi -qmaxmem=-1"
+ ;;
esac
if test "$assertions" = 'true'; then