summaryrefslogtreecommitdiff
path: root/setup.py
diff options
context:
space:
mode:
authorErlend Egeberg Aasland <erlend.aasland@innova.no>2021-11-23 08:52:05 +0100
committerGitHub <noreply@github.com>2021-11-23 08:52:05 +0100
commitd82f2caf942fa8b94e797a2f116ee54ec303c2df (patch)
tree770322bf217be774f6dfeac075d6c0504796788e /setup.py
parent758a23d1c4db97b578bc16e0ea110074d65c4c52 (diff)
downloadcpython-git-d82f2caf942fa8b94e797a2f116ee54ec303c2df.tar.gz
bpo-45847: Port _socket to PY_STDLIB_MOD (GH-29713)
Diffstat (limited to 'setup.py')
-rw-r--r--setup.py6
1 files changed, 2 insertions, 4 deletions
diff --git a/setup.py b/setup.py
index a3d377a696..304168a657 100644
--- a/setup.py
+++ b/setup.py
@@ -1034,6 +1034,8 @@ class PyBuildExt(build_ext):
self.addext(Extension('fcntl', ['fcntlmodule.c']))
# grp(3)
self.addext(Extension('grp', ['grpmodule.c']))
+
+ self.addext(Extension('_socket', ['socketmodule.c']))
self.addext(Extension('spwd', ['spwdmodule.c']))
# select(2); not on ancient System V
@@ -1254,9 +1256,6 @@ class PyBuildExt(build_ext):
self.add(Extension('_crypt', ['_cryptmodule.c'], libraries=libs))
- def detect_socket(self):
- self.add(Extension('_socket', ['socketmodule.c']))
-
def detect_dbm_gdbm(self):
# Modules that provide persistent dictionary-like semantics. You will
# probably want to arrange for at least one of them to be available on
@@ -1460,7 +1459,6 @@ class PyBuildExt(build_ext):
self.detect_test_extensions()
self.detect_readline_curses()
self.detect_crypt()
- self.detect_socket()
self.detect_openssl_hashlib()
self.detect_hash_builtins()
self.detect_dbm_gdbm()