summaryrefslogtreecommitdiff
path: root/setup.py
diff options
context:
space:
mode:
authorCharles Pigott <charlespigott@googlemail.com>2019-04-26 16:38:12 +0100
committerBerker Peksag <berker.peksag@gmail.com>2019-04-26 18:38:12 +0300
commitad0daf5b374dc43540d4ffcf32ca30e5c5147b90 (patch)
tree1bb0b6fbec1d99e200ea16db790aebc561cffcab /setup.py
parent06d04e77ca36133e82bf6c363c09ba82e07a9c75 (diff)
downloadcpython-git-ad0daf5b374dc43540d4ffcf32ca30e5c5147b90.tar.gz
bpo-31525: Increase minimum sqlite version number check (GH-12923)
Diffstat (limited to 'setup.py')
-rw-r--r--setup.py6
1 files changed, 3 insertions, 3 deletions
diff --git a/setup.py b/setup.py
index 58c16e8ba4..96a49b4e35 100644
--- a/setup.py
+++ b/setup.py
@@ -1299,7 +1299,7 @@ class PyBuildExt(build_ext):
sqlite_setup_debug = False # verbose debug prints from this script?
# We hunt for #define SQLITE_VERSION "n.n.n"
- # We need to find >= sqlite version 3.0.8
+ # We need to find >= sqlite version 3.3.9, for sqlite3_prepare_v2
sqlite_incdir = sqlite_libdir = None
sqlite_inc_paths = [ '/usr/include',
'/usr/include/sqlite',
@@ -1310,7 +1310,7 @@ class PyBuildExt(build_ext):
]
if CROSS_COMPILING:
sqlite_inc_paths = []
- MIN_SQLITE_VERSION_NUMBER = (3, 0, 8)
+ MIN_SQLITE_VERSION_NUMBER = (3, 3, 9)
MIN_SQLITE_VERSION = ".".join([str(x)
for x in MIN_SQLITE_VERSION_NUMBER])
@@ -1344,7 +1344,7 @@ class PyBuildExt(build_ext):
break
else:
if sqlite_setup_debug:
- print("%s: version %d is too old, need >= %s"%(d,
+ print("%s: version %s is too old, need >= %s"%(d,
sqlite_version, MIN_SQLITE_VERSION))
elif sqlite_setup_debug:
print("sqlite: %s had no SQLITE_VERSION"%(f,))