diff options
author | Erlend Egeberg Aasland <erlend.aasland@innova.no> | 2021-11-22 21:27:05 +0100 |
---|---|---|
committer | GitHub <noreply@github.com> | 2021-11-22 21:27:05 +0100 |
commit | 2dc7d3dda61e7ce07721f46b14c706fbc879dfd6 (patch) | |
tree | 084f525a4f3cfb66ebf1dbcde5eee0c0be33182e /setup.py | |
parent | 1037ca5a8ea001bfa2a198e08655620234e9befd (diff) | |
download | cpython-git-2dc7d3dda61e7ce07721f46b14c706fbc879dfd6.tar.gz |
bpo-45847: Port xxlimited and xxlimited_35 to PY_STDLIB_MOD (GH-29707)
Diffstat (limited to 'setup.py')
-rw-r--r-- | setup.py | 10 |
1 files changed, 4 insertions, 6 deletions
@@ -1477,13 +1477,11 @@ class PyBuildExt(build_ext): self.missing.append('_tkinter') self.detect_uuid() -## # Uncomment these lines if you want to play with xxmodule.c -## self.add(Extension('xx', ['xxmodule.c'])) + # Uncomment the next line if you want to play with xxmodule.c +# self.add(Extension('xx', ['xxmodule.c'])) - # The limited C API is not compatible with the Py_TRACE_REFS macro. - if not sysconfig.get_config_var('Py_TRACE_REFS'): - self.add(Extension('xxlimited', ['xxlimited.c'])) - self.add(Extension('xxlimited_35', ['xxlimited_35.c'])) + self.addext(Extension('xxlimited', ['xxlimited.c'])) + self.addext(Extension('xxlimited_35', ['xxlimited_35.c'])) def detect_tkinter_fromenv(self): # Build _tkinter using the Tcl/Tk locations specified by |