diff options
author | Ronald Oussoren <ronaldoussoren@mac.com> | 2013-07-15 18:32:09 +0200 |
---|---|---|
committer | Ronald Oussoren <ronaldoussoren@mac.com> | 2013-07-15 18:32:09 +0200 |
commit | 0fedb37c47971b75e644b05e5a467dad2a77620b (patch) | |
tree | b2388d2ce0163e9c28aedcf2830720aac2a5d948 /setup.py | |
parent | 7f93b36e73b9006772359c02255a468fe7df3fcd (diff) | |
download | cpython-git-0fedb37c47971b75e644b05e5a467dad2a77620b.tar.gz |
Issue #18393: Remove use of deprecated API on OSX
The "Gestalt" function on OSX is deprecated (starting with OSX 10.8),
remove its usage from the stdlib. The patch removes a number of private
functions and a private module, but does not change the public API.
The removed code was effectively dead, the platform module has used
other code to fetch the OSX version for years and could only use
on the Gestalt-based code as a fallback. That fallback can only trigger
on broken OSX installs (that is, someone has removed parts of the system
install)
Diffstat (limited to 'setup.py')
-rw-r--r-- | setup.py | 4 |
1 files changed, 0 insertions, 4 deletions
@@ -1520,10 +1520,6 @@ class PyBuildExt(build_ext): if host_platform == 'darwin': exts.append( - Extension('_gestalt', ['_gestalt.c'], - extra_link_args=['-framework', 'Carbon']) - ) - exts.append( Extension('_scproxy', ['_scproxy.c'], extra_link_args=[ '-framework', 'SystemConfiguration', |