summaryrefslogtreecommitdiff
path: root/configure.ac
diff options
context:
space:
mode:
authorNed Deily <nad@acm.org>2013-09-06 01:07:05 -0700
committerNed Deily <nad@acm.org>2013-09-06 01:07:05 -0700
commitd819b931f35852e1399f73ea19b74920ffde2651 (patch)
treef39225228fc4009d774d5a217bebcb15fb55fe57 /configure.ac
parentd80f7be580bf9f6bcf2c7ae99c6a8afde6aafc6c (diff)
downloadcpython-git-d819b931f35852e1399f73ea19b74920ffde2651.tar.gz
Issue #1584: Provide options to override default search paths for Tcl and Tk
when building _tkinter. configure has two new options; if used, both must be specified: ./configure \ --with-tcltk-includes="-I/opt/local/include" \ --with-tcltk-libs="-L/opt/local/lib -ltcl8.5 -ltk8.5" In addition, the options can be overridden with make: make \ TCLTK_INCLUDES="-I/opt/local/include" \ TCLTK_LIBS="-L/opt/local/lib -ltcl8.6 -ltk8.6"
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac28
1 files changed, 28 insertions, 0 deletions
diff --git a/configure.ac b/configure.ac
index 036ddbd553..c63e34b96a 100644
--- a/configure.ac
+++ b/configure.ac
@@ -2282,6 +2282,34 @@ AC_ARG_ENABLE(loadable-sqlite-extensions,
AC_MSG_RESULT($enable_loadable_sqlite_extensions)
+# Check for --with-tcltk-includes=path and --with-tcltk-libs=path
+AC_SUBST(TCLTK_INCLUDES)
+AC_SUBST(TCLTK_LIBS)
+AC_MSG_CHECKING(for --with-tcltk-includes)
+AC_ARG_WITH(tcltk-includes,
+ AS_HELP_STRING([--with-tcltk-includes='-I...'], [override search for Tcl and Tk include files]),
+ [],
+ [with_tcltk_includes="default"])
+AC_MSG_RESULT($with_tcltk_includes)
+AC_MSG_CHECKING(for --with-tcltk-libs)
+AC_ARG_WITH(tcltk-libs,
+ AS_HELP_STRING([--with-tcltk-libs='-L...'], [override search for Tcl and Tk libs]),
+ [],
+ [with_tcltk_libs="default"])
+AC_MSG_RESULT($with_tcltk_libs)
+if test "x$with_tcltk_includes" = xdefault || test "x$with_tcltk_libs" = xdefault
+then
+ if test "x$with_tcltk_includes" != "x$with_tcltk_libs"
+ then
+ AC_MSG_ERROR([use both --with-tcltk-includes='...' and --with-tcltk-libs='...' or neither])
+ fi
+ TCLTK_INCLUDES=""
+ TCLTK_LIBS=""
+else
+ TCLTK_INCLUDES="$with_tcltk_includes"
+ TCLTK_LIBS="$with_tcltk_libs"
+fi
+
# Check for --with-dbmliborder
AC_MSG_CHECKING(for --with-dbmliborder)
AC_ARG_WITH(dbmliborder,