summaryrefslogtreecommitdiff
path: root/configure.ac
diff options
context:
space:
mode:
authorEthan Smith <ethan@ethanhs.me>2022-04-28 05:14:19 -0700
committerGitHub <noreply@github.com>2022-04-28 05:14:19 -0700
commitd1de10784d9678d14759d0d03216431d1090e60e (patch)
tree41a6ed1074400ac9a2cf54eb60334425d603db5c /configure.ac
parent87c6cf9aa7cebac3c544067e690c2ad7ce18b772 (diff)
downloadcpython-git-d1de10784d9678d14759d0d03216431d1090e60e.tar.gz
gh-84461: Add HOSTRUNNER for program to run Python executable (GH-91931)
`HOSTRUNNER` is a program which can be used to run `BUILDPYTHON` for the host platform (for example, `python.js` requires `node`). Also change depedencies from `build_all` to `all` so that targets which can't build everything (e.g. WASM) can still run `buildbottest` and `pythoninfo`. cc @tiran
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac18
1 files changed, 18 insertions, 0 deletions
diff --git a/configure.ac b/configure.ac
index 86839547e2..62da321a98 100644
--- a/configure.ac
+++ b/configure.ac
@@ -1412,6 +1412,24 @@ if test "$cross_compiling" = yes; then
RUNSHARED=
fi
+AC_ARG_VAR([HOSTRUNNER], [Program to run CPython for the host platform])
+AC_MSG_CHECKING([HOSTRUNNER])
+if test -z "$HOSTRUNNER"
+then
+ AS_CASE([$ac_sys_system/$ac_sys_emscripten_target],
+ [Emscripten/node*], [
+ AS_VAR_IF([enable_wasm_pthreads], [yes], [
+ HOSTRUNNER='node --experimental-wasm-threads --experimental-wasm-bulk-memory'
+ ], [
+ HOSTRUNNER='node'
+ ])
+ ],
+ [HOSTRUNNER='']
+ )
+fi
+AC_SUBST([HOSTRUNNER])
+AC_MSG_RESULT([$HOSTRUNNER])
+
AC_MSG_RESULT($LDLIBRARY)
# LIBRARY_DEPS, LINK_PYTHON_OBJS and LINK_PYTHON_DEPS variable