summaryrefslogtreecommitdiff
path: root/configure.ac
diff options
context:
space:
mode:
authorBenjamin Peterson <benjamin@python.org>2018-09-12 06:51:18 -0700
committerGitHub <noreply@github.com>2018-09-12 06:51:18 -0700
commit865c17fb28f8c3275fd94da6ee4ac51472ec874a (patch)
treeb66adfd7ef7d535b923e4d8eabd2475b2acbdbcc /configure.ac
parent7f0d59f3a83cf1a98398b8e5bdfb97c7a71216bd (diff)
downloadcpython-git-865c17fb28f8c3275fd94da6ee4ac51472ec874a.tar.gz
closes bpo-34640: Remove the TANH_PRESERVES_ZERO_SIGN configure check. (GH-9206)
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac27
1 files changed, 0 insertions, 27 deletions
diff --git a/configure.ac b/configure.ac
index 4b34bad35a..a985ec2b00 100644
--- a/configure.ac
+++ b/configure.ac
@@ -4359,33 +4359,6 @@ AC_CHECK_FUNCS([acosh asinh atanh copysign erf erfc expm1 finite gamma])
AC_CHECK_FUNCS([hypot lgamma log1p log2 round tgamma])
AC_CHECK_DECLS([isinf, isnan, isfinite], [], [], [[#include <math.h>]])
-# On FreeBSD 6.2, it appears that tanh(-0.) returns 0. instead of
-# -0. on some architectures.
-AC_MSG_CHECKING(whether tanh preserves the sign of zero)
-AC_CACHE_VAL(ac_cv_tanh_preserves_zero_sign, [
-AC_RUN_IFELSE([AC_LANG_SOURCE([[
-#include <math.h>
-#include <stdlib.h>
-int main() {
- /* return 0 if either negative zeros don't exist
- on this platform or if negative zeros exist
- and tanh(-0.) == -0. */
- if (atan2(0., -1.) == atan2(-0., -1.) ||
- atan2(tanh(-0.), -1.) == atan2(-0., -1.)) exit(0);
- else exit(1);
-}
-]])],
-[ac_cv_tanh_preserves_zero_sign=yes],
-[ac_cv_tanh_preserves_zero_sign=no],
-[ac_cv_tanh_preserves_zero_sign=no])])
-AC_MSG_RESULT($ac_cv_tanh_preserves_zero_sign)
-if test "$ac_cv_tanh_preserves_zero_sign" = yes
-then
- AC_DEFINE(TANH_PRESERVES_ZERO_SIGN, 1,
- [Define if tanh(-0.) is -0., or if platform doesn't have signed zeros])
-fi
-LIBS=$LIBS_SAVE
-
# For multiprocessing module, check that sem_open
# actually works. For FreeBSD versions <= 7.2,
# the kernel module that provides POSIX semaphores