summaryrefslogtreecommitdiff
path: root/configure.ac
diff options
context:
space:
mode:
authorVictor Stinner <vstinner@redhat.com>2019-04-26 18:56:19 +0200
committerGitHub <noreply@github.com>2019-04-26 18:56:19 +0200
commit6d13e5b35ba7165db3f38fccdd6e1e5283f96a74 (patch)
tree2ce1c2c8427548f0f018afd3b680447d3bd144a9 /configure.ac
parent404606974051c5ec093312aa57cf1bcbc52e1d85 (diff)
downloadcpython-git-6d13e5b35ba7165db3f38fccdd6e1e5283f96a74.tar.gz
bpo-36722: Don't define ALT_SOABI for Py_TRACE_REFS build (GH-12973)
Py_TRACE_REFS ABI is incompatible with release and debug (Py_DEBUG) ABI.
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac3
1 files changed, 2 insertions, 1 deletions
diff --git a/configure.ac b/configure.ac
index 312758788e..157e9bf406 100644
--- a/configure.ac
+++ b/configure.ac
@@ -4627,7 +4627,8 @@ AC_MSG_CHECKING(SOABI)
SOABI='cpython-'`echo $VERSION | tr -d .`${ABIFLAGS}${PLATFORM_TRIPLET:+-$PLATFORM_TRIPLET}
AC_MSG_RESULT($SOABI)
-if test "$Py_DEBUG" = 'true'; then
+# Release and debug (Py_DEBUG) ABI are compatible, but not Py_TRACE_REFS ABI
+if test "$Py_DEBUG" = 'true' -a "$with_trace_refs" != "yes"; then
# Similar to SOABI but remove "d" flag from ABIFLAGS
AC_SUBST(ALT_SOABI)
ALT_SOABI='cpython-'`echo $VERSION | tr -d .``echo $ABIFLAGS | tr -d d`${PLATFORM_TRIPLET:+-$PLATFORM_TRIPLET}