summaryrefslogtreecommitdiff
path: root/configure.ac
diff options
context:
space:
mode:
authorBenjamin Peterson <benjamin@python.org>2018-09-11 16:30:04 -0700
committerMiss Islington (bot) <31488909+miss-islington@users.noreply.github.com>2018-09-11 16:30:04 -0700
commit50c99d917c0eded2afcad0a3d7e49475a76440a3 (patch)
tree334ddf411a45912e5e07d2872cd7714f9a405499 /configure.ac
parent6c7d67ce83a62b5f0fe5c53a6df602827451bf7f (diff)
downloadcpython-git-50c99d917c0eded2afcad0a3d7e49475a76440a3.tar.gz
Remove configure check LOG1P_DROPS_ZERO_SIGN. (GH-9193)
It is unused. <!-- Thanks for your contribution! Please read this comment in its entirety. It's quite important. # Pull Request title It should be in the following format: ``` bpo-NNNN: Summary of the changes made ``` Where: bpo-NNNN refers to the issue number in the https://bugs.python.org. Most PRs will require an issue number. Trivial changes, like fixing a typo, do not need an issue. # Backport Pull Request title If this is a backport PR (PR made against branches other than `master`), please ensure that the PR title is in the following format: ``` [X.Y] <title from the original PR> (GH-NNNN) ``` Where: [X.Y] is the branch name, e.g. [3.6]. GH-NNNN refers to the PR number from `master`. -->
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac30
1 files changed, 0 insertions, 30 deletions
diff --git a/configure.ac b/configure.ac
index e47586bd40..4b34bad35a 100644
--- a/configure.ac
+++ b/configure.ac
@@ -4384,36 +4384,6 @@ then
AC_DEFINE(TANH_PRESERVES_ZERO_SIGN, 1,
[Define if tanh(-0.) is -0., or if platform doesn't have signed zeros])
fi
-
-if test "$ac_cv_func_log1p" = yes
-then
- # On some versions of AIX, log1p(-0.) returns 0. instead of
- # -0. See issue #9920.
- AC_MSG_CHECKING(whether log1p drops the sign of negative zero)
- AC_CACHE_VAL(ac_cv_log1p_drops_zero_sign, [
- AC_RUN_IFELSE([AC_LANG_SOURCE([[
- #include <math.h>
- #include <stdlib.h>
- int main() {
- /* Fail if the signs of log1p(-0.) and -0. can be
- distinguished. */
- if (atan2(log1p(-0.), -1.) == atan2(-0., -1.))
- return 0;
- else
- return 1;
- }
- ]])],
- [ac_cv_log1p_drops_zero_sign=no],
- [ac_cv_log1p_drops_zero_sign=yes],
- [ac_cv_log1p_drops_zero_sign=no])])
- AC_MSG_RESULT($ac_cv_log1p_drops_zero_sign)
-fi
-if test "$ac_cv_log1p_drops_zero_sign" = yes
-then
- AC_DEFINE(LOG1P_DROPS_ZERO_SIGN, 1,
- [Define if log1p(-0.) is 0. rather than -0.])
-fi
-
LIBS=$LIBS_SAVE
# For multiprocessing module, check that sem_open