summaryrefslogtreecommitdiff
path: root/configure.ac
diff options
context:
space:
mode:
authorBenjamin Peterson <benjamin@python.org>2013-08-23 21:01:48 -0500
committerBenjamin Peterson <benjamin@python.org>2013-08-23 21:01:48 -0500
commit3a7dffa4cec84c94685fc9dccbded8ee41904fd5 (patch)
tree4dd078de4f3cc6fce7c9298689bdc76e27ed8117 /configure.ac
parent12d5e0f01693686a96eb45af88c2b7f7c6caaac6 (diff)
downloadcpython-git-3a7dffa4cec84c94685fc9dccbded8ee41904fd5.tar.gz
remove support for compiling on systems without getcwd()
Do we need a fallback implementation of getcwd() from 1991 that claims to support "really old Unix systems"? I don't think so.
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac2
1 files changed, 1 insertions, 1 deletions
diff --git a/configure.ac b/configure.ac
index 47f5c57924..e329c214cb 100644
--- a/configure.ac
+++ b/configure.ac
@@ -3094,7 +3094,7 @@ AC_CHECK_FUNCS(memmove)
# check for long file support functions
AC_CHECK_FUNCS(fseek64 fseeko fstatvfs ftell64 ftello statvfs)
-AC_REPLACE_FUNCS(dup2 getcwd strdup)
+AC_REPLACE_FUNCS(dup2 strdup)
AC_CHECK_FUNCS(getpgrp,
AC_COMPILE_IFELSE([AC_LANG_PROGRAM([[#include <unistd.h>]], [[getpgrp(0);]])],
[AC_DEFINE(GETPGRP_HAVE_ARG, 1, [Define if getpgrp() must be called as getpgrp(0).])],