summaryrefslogtreecommitdiff
path: root/configure.ac
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2023-01-11 22:46:28 +0100
committerGitHub <noreply@github.com>2023-01-11 22:46:28 +0100
commit02a72f080dc89b037c304a85a0f96509de9ae688 (patch)
treec3a86320187d36542843d340c84a9f6e4972a47f /configure.ac
parent07a87f74faf31cdd755ac7de6d44531139899d1b (diff)
downloadcpython-git-02a72f080dc89b037c304a85a0f96509de9ae688.tar.gz
gh-98636: Fix detecting gdbm_compat for _dbm module (#98643)
Fix the gdbm_compat library detection logic to actually check for -lgdbm_compat independently of the ndbm detection. This fixes the build failure with `--with-dbmliborder=gdbm`, and implicit fallback to ndbm with the default value.
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac3
1 files changed, 2 insertions, 1 deletions
diff --git a/configure.ac b/configure.ac
index 0ed5a24e86..956334a865 100644
--- a/configure.ac
+++ b/configure.ac
@@ -4120,8 +4120,9 @@ AS_VAR_IF([ac_cv_header_gdbm_dash_ndbm_h], [yes], [
AS_UNSET([ac_cv_header_gdbm_ndbm_h])
if test "$ac_cv_header_gdbm_slash_ndbm_h" = yes -o "$ac_cv_header_gdbm_dash_ndbm_h" = yes; then
+ AS_UNSET([ac_cv_search_dbm_open])
WITH_SAVE_ENV([
- AC_SEARCH_LIBS([dbm_open], [gdbm_compat])
+ AC_SEARCH_LIBS([dbm_open], [gdbm_compat], [have_gdbm_compat=yes], [have_gdbm_compat=no])
])
fi