summaryrefslogtreecommitdiff
path: root/pyproject.toml
diff options
context:
space:
mode:
authorBenjamin Schubert <contact@benschubert.me>2019-05-26 09:37:26 +0100
committerBenjamin Schubert <contact@benschubert.me>2019-05-29 19:47:57 +0100
commit4e9b5803e7241cc87c14126d320dc744ac4798cf (patch)
tree1f1d3bc9756b70a49defe57e73bdd3f4940504fe /pyproject.toml
parentd220c4c3bcf31b9d4660a6e915e70269c891bd9f (diff)
downloadbuildstream-4e9b5803e7241cc87c14126d320dc744ac4798cf.tar.gz
Introduce Cython to the project and document
Cython requires a plugin to allow coverage of cython files, which was updated in coveragerc. It also means we need to build the dependencies and install cython for coverage. Cython requires access to both source and compiled files when running coverage. We therefore need to install project in develop mode. Updated documentation to explain how to run tests without tox but with coverage
Diffstat (limited to 'pyproject.toml')
-rw-r--r--pyproject.toml3
1 files changed, 2 insertions, 1 deletions
diff --git a/pyproject.toml b/pyproject.toml
index 38bb870e3..4dd02d1e5 100644
--- a/pyproject.toml
+++ b/pyproject.toml
@@ -3,6 +3,7 @@ requires = [
# We need at least version 36.6.0 that introduced "build_meta"
"setuptools>=36.6.0",
# In order to build wheels, and as required by PEP 517
- "wheel"
+ "wheel",
+ "Cython"
]
build-backend = "setuptools.build_meta"