summaryrefslogtreecommitdiff
path: root/pyproject.toml
diff options
context:
space:
mode:
authorBenjamin Schubert <contact@benschubert.me>2019-05-18 14:01:08 +0100
committerBenjamin Schubert <contact@benschubert.me>2019-05-29 19:47:57 +0100
commitd220c4c3bcf31b9d4660a6e915e70269c891bd9f (patch)
tree249c9a16fe33a7af41b71e035abbbbee0268daba /pyproject.toml
parent7c9004b0d2836f8c2349f13f9e3d4bdc1eb6b8ed (diff)
downloadbuildstream-d220c4c3bcf31b9d4660a6e915e70269c891bd9f.tar.gz
Introduce pyproject.toml
Using pyproject.toml, defined in PEP518, allows us to have an isolated build environment, ensuring that Cython can be installed before calling setup.py in tox. This allows us to use cython helpers in the setup.py script. This is a prerequisite for introducing Cython in the codebase
Diffstat (limited to 'pyproject.toml')
-rw-r--r--pyproject.toml8
1 files changed, 8 insertions, 0 deletions
diff --git a/pyproject.toml b/pyproject.toml
new file mode 100644
index 000000000..38bb870e3
--- /dev/null
+++ b/pyproject.toml
@@ -0,0 +1,8 @@
+[build-system]
+requires = [
+ # We need at least version 36.6.0 that introduced "build_meta"
+ "setuptools>=36.6.0",
+ # In order to build wheels, and as required by PEP 517
+ "wheel"
+]
+build-backend = "setuptools.build_meta"