summaryrefslogtreecommitdiff
path: root/configure.ac
diff options
context:
space:
mode:
authorAkim Demaille <akim.demaille@gmail.com>2019-01-15 20:42:18 +0100
committerAkim Demaille <akim.demaille@gmail.com>2019-01-15 20:43:27 +0100
commita634aad9e639db7ea204473f2edafc294fb49ca2 (patch)
treecbe92a5093cc3d83c93909ac8ce4ec09ae62bb6c /configure.ac
parentad326ada91b35bc464456c1b8bd8ef22793834a9 (diff)
downloadbison-a634aad9e639db7ea204473f2edafc294fb49ca2.tar.gz
configure: don't try to run C++ warnings on C
Reported by Derek Clegg. https://lists.gnu.org/archive/html/bison-patches/2019-01/msg00066.html * configure.ac: here.
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac4
1 files changed, 2 insertions, 2 deletions
diff --git a/configure.ac b/configure.ac
index 23aeb86d..a3a471af 100644
--- a/configure.ac
+++ b/configure.ac
@@ -98,9 +98,9 @@ if test "$enable_gcc_warnings" = yes; then
-fparse-all-comments -Wdocumentation
-Wformat -Wimplicit-fallthrough -Wnull-dereference
-Wpointer-arith -Wshadow
- -Wundefined-func-template -Wwrite-strings'
+ -Wwrite-strings'
warn_c='-Wbad-function-cast -Wstrict-prototypes'
- warn_cxx='-Wextra-semi -Wnoexcept'
+ warn_cxx='-Wextra-semi -Wnoexcept -Wundefined-func-template'
# Warnings for the test suite only.
#
# -fno-color-diagnostics: Clang's use of colors in the error