summaryrefslogtreecommitdiff
path: root/configure.ac
diff options
context:
space:
mode:
authorAkim Demaille <akim.demaille@gmail.com>2019-01-15 07:43:16 +0100
committerAkim Demaille <akim.demaille@gmail.com>2019-01-15 18:07:00 +0100
commitad326ada91b35bc464456c1b8bd8ef22793834a9 (patch)
treefcde254cf73744f4c0a0e4aa27dbb0c090929f42 /configure.ac
parenta049509d0437046e57a0e96f71452ddb33f8eecc (diff)
downloadbison-ad326ada91b35bc464456c1b8bd8ef22793834a9.tar.gz
c, c++: avoid implicit fall-throw
Reported by Derek Clegg. http://lists.gnu.org/archive/html/bug-bison/2019-01/msg00004.html * configure.ac (warn_common): Add -Wimplicit-fallthrough. This does trigger failures in the test suite. * data/skeletons/glr.c, data/skeletons/lalr1.cc, * data/skeletons/yacc.c, tests/c++.at: Make fall-throws explicit.
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac3
1 files changed, 2 insertions, 1 deletions
diff --git a/configure.ac b/configure.ac
index b7ba45dc..23aeb86d 100644
--- a/configure.ac
+++ b/configure.ac
@@ -96,7 +96,8 @@ AM_CONDITIONAL([ENABLE_GCC_WARNINGS], [test "$enable_gcc_warnings" = yes])
if test "$enable_gcc_warnings" = yes; then
warn_common='-Wall -Wextra -Wno-sign-compare -Wcast-align
-fparse-all-comments -Wdocumentation
- -Wformat -Wnull-dereference -Wpointer-arith -Wshadow
+ -Wformat -Wimplicit-fallthrough -Wnull-dereference
+ -Wpointer-arith -Wshadow
-Wundefined-func-template -Wwrite-strings'
warn_c='-Wbad-function-cast -Wstrict-prototypes'
warn_cxx='-Wextra-semi -Wnoexcept'