summaryrefslogtreecommitdiff
path: root/configure.ac
diff options
context:
space:
mode:
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac16
1 files changed, 16 insertions, 0 deletions
diff --git a/configure.ac b/configure.ac
index c84263c516b..c205698cd6b 100644
--- a/configure.ac
+++ b/configure.ac
@@ -901,6 +901,22 @@ case "${target}" in
;;
esac
+# Targets that do not use the ELF file format cannot support libctf.
+case "${target}" in
+ *-*-pe | *-*-*vms* | *-*-darwin | *-*-*coff* | *-*-wince | *-*-mingw*)
+ noconfigdirs="$noconfigdirs libctf"
+ ;;
+ *-*-aout | *-*-osf* | *-*-go32 | *-*-macos* | *-*-rhapsody*)
+ noconfigdirs="$noconfigdirs libctf"
+ ;;
+ *-*-netbsdpe | *-*-cygwin* | *-*-pep | *-*-msdos | *-*-winnt)
+ noconfigdirs="$noconfigdirs libctf"
+ ;;
+ ns32k-*-* | pdp11-*-* | *-*-aix* | *-*-netbsdaout)
+ noconfigdirs="$noconfigdirs libctf"
+ ;;
+esac
+
case "${target}" in
*-*-chorusos)
;;