summaryrefslogtreecommitdiff
path: root/configure.ac
diff options
context:
space:
mode:
authorNick Clifton <nickc@redhat.com>2019-05-29 11:31:16 +0100
committerNick Clifton <nickc@redhat.com>2019-05-29 11:32:34 +0100
commit90bd54236cb8b1c31c3662977159be971044c20d (patch)
treeae40336bf812074b3c26b51190e33a59946ef2e8 /configure.ac
parent9698cf9b1c485edbbeabc9f65bfd0fdef92e3854 (diff)
downloadbinutils-gdb-90bd54236cb8b1c31c3662977159be971044c20d.tar.gz
Do not build libctf for targets that do not use the ELF file format.
top * configure.ac (noconfigdirs): Add libctf if the target does not use the ELF file format. * configure: Regenerate. binutils* configure.ac (LIBCTF): Export. Set to empty for non-ELF based targets. (HAVE_LIBCTF): Define if libctf support is available. * Makefile.am (LIBCTF): Set value to @LIBCTF@. * objdump.c: Make CTF code conditional upon HAVE_LIBCTF being defined. * readelf.c: Likewise. * configure: Regenerate. * Makefile.in: Regenerate. * config.in: Regenerate.
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac16
1 files changed, 16 insertions, 0 deletions
diff --git a/configure.ac b/configure.ac
index c84263c516b..c205698cd6b 100644
--- a/configure.ac
+++ b/configure.ac
@@ -901,6 +901,22 @@ case "${target}" in
;;
esac
+# Targets that do not use the ELF file format cannot support libctf.
+case "${target}" in
+ *-*-pe | *-*-*vms* | *-*-darwin | *-*-*coff* | *-*-wince | *-*-mingw*)
+ noconfigdirs="$noconfigdirs libctf"
+ ;;
+ *-*-aout | *-*-osf* | *-*-go32 | *-*-macos* | *-*-rhapsody*)
+ noconfigdirs="$noconfigdirs libctf"
+ ;;
+ *-*-netbsdpe | *-*-cygwin* | *-*-pep | *-*-msdos | *-*-winnt)
+ noconfigdirs="$noconfigdirs libctf"
+ ;;
+ ns32k-*-* | pdp11-*-* | *-*-aix* | *-*-netbsdaout)
+ noconfigdirs="$noconfigdirs libctf"
+ ;;
+esac
+
case "${target}" in
*-*-chorusos)
;;