summaryrefslogtreecommitdiff
path: root/utests/CMakeLists.txt
diff options
context:
space:
mode:
authorGrigore Lupescu <grigore.lupescu at intel.com>2016-04-11 17:40:18 +0300
committerYang Rong <rong.r.yang@intel.com>2016-05-18 15:10:36 +0800
commitf2504739d7fbf0cc42925bfd824e5a3c01020a15 (patch)
treedb40922e069292a1c116e12aee9a16989fceb77e /utests/CMakeLists.txt
parent2fb94e3ad11a410885808bb8f7cf1b04e2abc7a9 (diff)
downloadbeignet-f2504739d7fbf0cc42925bfd824e5a3c01020a15.tar.gz
Utest: Add workgroup scan inclusive tests
Added the following unit tests: compiler_workgroup_scan_inclusive_add_int compiler_workgroup_scan_inclusive_add_uint compiler_workgroup_scan_inclusive_add_long compiler_workgroup_scan_inclusive_add_ulong compiler_workgroup_scan_inclusive_add_float compiler_workgroup_scan_inclusive_max_int compiler_workgroup_scan_inclusive_max_uint compiler_workgroup_scan_inclusive_max_long compiler_workgroup_scan_inclusive_max_ulong compiler_workgroup_scan_inclusive_max_float compiler_workgroup_scan_inclusive_min_int compiler_workgroup_scan_inclusive_min_uint compiler_workgroup_scan_inclusive_min_long compiler_workgroup_scan_inclusive_min_ulong compiler_workgroup_scan_inclusive_min_float Signed-off-by: Grigore Lupescu <grigore.lupescu at intel.com> Reviewed-by: Pan Xiuli <xiuli.pan@intel.com>
Diffstat (limited to 'utests/CMakeLists.txt')
-rw-r--r--utests/CMakeLists.txt1
1 files changed, 1 insertions, 0 deletions
diff --git a/utests/CMakeLists.txt b/utests/CMakeLists.txt
index 865ca0c7..26a22647 100644
--- a/utests/CMakeLists.txt
+++ b/utests/CMakeLists.txt
@@ -165,6 +165,7 @@ set (utests_sources
compiler_workgroup_broadcast.cpp
compiler_workgroup_reduce.cpp
compiler_workgroup_scan_exclusive.cpp
+ compiler_workgroup_scan_inclusive.cpp
compiler_async_stride_copy.cpp
compiler_insn_selection_min.cpp
compiler_insn_selection_max.cpp