summaryrefslogtreecommitdiff
path: root/utests/CMakeLists.txt
diff options
context:
space:
mode:
authorGrigore Lupescu <grigore.lupescu at intel.com>2016-04-11 17:40:00 +0300
committerYang Rong <rong.r.yang@intel.com>2016-05-18 15:10:36 +0800
commit2fb94e3ad11a410885808bb8f7cf1b04e2abc7a9 (patch)
tree80c88b85b8fe98efafacc58bf52cf04d70ebc00a /utests/CMakeLists.txt
parent4bf8346d24970ba5d950f7e04131a8b633ff1fda (diff)
downloadbeignet-2fb94e3ad11a410885808bb8f7cf1b04e2abc7a9.tar.gz
Utest: Add workgroup scan exclusive tests
Added the following unit tests: compiler_workgroup_scan_exclusive_add_int compiler_workgroup_scan_exclusive_add_uint compiler_workgroup_scan_exclusive_add_long compiler_workgroup_scan_exclusive_add_ulong compiler_workgroup_scan_exclusive_add_float compiler_workgroup_scan_exclusive_max_int compiler_workgroup_scan_exclusive_max_uint compiler_workgroup_scan_exclusive_max_long compiler_workgroup_scan_exclusive_max_ulong compiler_workgroup_scan_exclusive_max_float compiler_workgroup_scan_exclusive_min_int compiler_workgroup_scan_exclusive_min_uint compiler_workgroup_scan_exclusive_min_long compiler_workgroup_scan_exclusive_min_ulong compiler_workgroup_scan_exclusive_min_float Signed-off-by: Grigore Lupescu <grigore.lupescu at intel.com> Reviewed-by: Pan Xiuli <xiuli.pan@intel.com>
Diffstat (limited to 'utests/CMakeLists.txt')
-rw-r--r--utests/CMakeLists.txt1
1 files changed, 1 insertions, 0 deletions
diff --git a/utests/CMakeLists.txt b/utests/CMakeLists.txt
index a76bc473..865ca0c7 100644
--- a/utests/CMakeLists.txt
+++ b/utests/CMakeLists.txt
@@ -164,6 +164,7 @@ set (utests_sources
compiler_async_copy.cpp
compiler_workgroup_broadcast.cpp
compiler_workgroup_reduce.cpp
+ compiler_workgroup_scan_exclusive.cpp
compiler_async_stride_copy.cpp
compiler_insn_selection_min.cpp
compiler_insn_selection_max.cpp