summaryrefslogtreecommitdiff
path: root/utests/CMakeLists.txt
diff options
context:
space:
mode:
authorGuo Yejun <yejun.guo@intel.com>2015-12-23 08:17:48 +0800
committerYang Rong <rong.r.yang@intel.com>2016-01-08 14:20:52 +0800
commitbd07f260cfb43f8d4f7b954fb7d7dc46e1989ba1 (patch)
tree4ec2a09be98fde348f8a47049bfa2b205ba2ae18 /utests/CMakeLists.txt
parente5bbba5b0fd856f71df9c22e13a512865f22d5df (diff)
downloadbeignet-bd07f260cfb43f8d4f7b954fb7d7dc46e1989ba1.tar.gz
change built-in function name from get_sub_group_id to get_sub_group_local_id
Fix bug at https://bugs.freedesktop.org/show_bug.cgi?id=93469 The fucntion is mapped to OP_SIMD_ID which returns the SIMD lane ID. However, the SIMD lane ID is the equivalent of get_sub_group_local_id(). contributor: Georg Kolling <georg.kolling@gmail.com> Signed-off-by: Guo Yejun <yejun.guo@intel.com> Reviewed-by: Yang Rong <rong.r.yang@intel.com>
Diffstat (limited to 'utests/CMakeLists.txt')
-rw-r--r--utests/CMakeLists.txt2
1 files changed, 1 insertions, 1 deletions
diff --git a/utests/CMakeLists.txt b/utests/CMakeLists.txt
index 2c6aea47..db62e380 100644
--- a/utests/CMakeLists.txt
+++ b/utests/CMakeLists.txt
@@ -221,7 +221,7 @@ set (utests_sources
runtime_alloc_host_ptr_buffer.cpp
runtime_use_host_ptr_image.cpp
compiler_get_max_sub_group_size.cpp
- compiler_get_sub_group_id.cpp
+ compiler_get_sub_group_local_id.cpp
compiler_sub_group_shuffle.cpp
builtin_global_linear_id.cpp
builtin_local_linear_id.cpp