summaryrefslogtreecommitdiff
path: root/utests/CMakeLists.txt
diff options
context:
space:
mode:
authorGuo Yejun <yejun.guo@intel.com>2015-12-23 08:15:08 +0800
committerYang Rong <rong.r.yang@intel.com>2016-01-08 14:20:50 +0800
commite5bbba5b0fd856f71df9c22e13a512865f22d5df (patch)
tree8d42917bf7e36284e516340581126f7ce282dec3 /utests/CMakeLists.txt
parentfc410ee2d6138bac821fe20a0d35c3b283244071 (diff)
downloadbeignet-e5bbba5b0fd856f71df9c22e13a512865f22d5df.tar.gz
change built-in function name from get_sub_group_size to get_max_sub_group_size
Fix bug at https://bugs.freedesktop.org/show_bug.cgi?id=93469 The fucntion is mapped to OP_SIMD_SIZE which returns the constant SIMD width, the correct function name is get_max_sub_group_size. contributor: Georg Kolling <georg.kolling@gmail.com> Signed-off-by: Guo Yejun <yejun.guo@intel.com> Reviewed-by: Yang Rong <rong.r.yang@intel.com>
Diffstat (limited to 'utests/CMakeLists.txt')
-rw-r--r--utests/CMakeLists.txt2
1 files changed, 1 insertions, 1 deletions
diff --git a/utests/CMakeLists.txt b/utests/CMakeLists.txt
index d846b7b7..2c6aea47 100644
--- a/utests/CMakeLists.txt
+++ b/utests/CMakeLists.txt
@@ -220,7 +220,7 @@ set (utests_sources
runtime_use_host_ptr_buffer.cpp
runtime_alloc_host_ptr_buffer.cpp
runtime_use_host_ptr_image.cpp
- compiler_get_sub_group_size.cpp
+ compiler_get_max_sub_group_size.cpp
compiler_get_sub_group_id.cpp
compiler_sub_group_shuffle.cpp
builtin_global_linear_id.cpp