summaryrefslogtreecommitdiff
path: root/utests/CMakeLists.txt
diff options
context:
space:
mode:
authorLuoXionghu <xionghu.luo@intel.com>2014-07-16 09:31:06 +0800
committerZhigang Gong <zhigang.gong@intel.com>2014-07-16 13:49:56 +0800
commit36644bb9e3e94dfea42e44ab92f48fd120db808f (patch)
tree7ce4a947158d8729223c61486637b0b35588cb82 /utests/CMakeLists.txt
parent958296cb14f7d5a34fb8a2c21e3230de71a5cab0 (diff)
downloadbeignet-36644bb9e3e94dfea42e44ab92f48fd120db808f.tar.gz
add utest load_program_from_gen_bin.
this test case would check whether genProgramSerializeToBinary in backend can generator gen binary correctly. rename load_program_from_bin to load_program_from_bin_file. the difference is load_program_from_bin_file could either load program from llvm binary or gen binary file generated by gbe_bin_generator. Signed-off-by: LuoXionghu <xionghu.luo@intel.com> Reviewed-by: Zhigang Gong <zhigang.gong@linux.intel.com>
Diffstat (limited to 'utests/CMakeLists.txt')
-rw-r--r--utests/CMakeLists.txt3
1 files changed, 2 insertions, 1 deletions
diff --git a/utests/CMakeLists.txt b/utests/CMakeLists.txt
index 3614c573..561744d2 100644
--- a/utests/CMakeLists.txt
+++ b/utests/CMakeLists.txt
@@ -171,7 +171,8 @@ set (utests_sources
compiler_simd_any.cpp
compiler_simd_all.cpp
compiler_double_precision.cpp
- load_program_from_bin.cpp
+ load_program_from_bin_file.cpp
+ load_program_from_gen_bin.cpp
get_arg_info.cpp
profiling_exec.cpp
enqueue_copy_buf.cpp