summaryrefslogtreecommitdiff
path: root/utests/CMakeLists.txt
diff options
context:
space:
mode:
authorPan Xiuli <xiuli.pan@intel.com>2016-05-17 07:38:13 +0800
committerYang Rong <rong.r.yang@intel.com>2016-06-13 17:02:28 +0800
commit0e8b5cbbf897f81fb229eaca34a398ae7393e915 (patch)
treeb32114e635bc31a2a05c443a567bee3135079ce4 /utests/CMakeLists.txt
parent8dbc3406631d4cdd65748ec61480b6272fbe6b5f (diff)
downloadbeignet-0e8b5cbbf897f81fb229eaca34a398ae7393e915.tar.gz
Utest: Add test case for sub_group functions
Long type need to be fixed before gen8, so hide them now. Signed-off-by: Pan Xiuli <xiuli.pan@intel.com> Reviewed-by: Yang Rong <rong.r.yang@intel.com>
Diffstat (limited to 'utests/CMakeLists.txt')
-rw-r--r--utests/CMakeLists.txt4
1 files changed, 4 insertions, 0 deletions
diff --git a/utests/CMakeLists.txt b/utests/CMakeLists.txt
index 7ea10e05..e7211792 100644
--- a/utests/CMakeLists.txt
+++ b/utests/CMakeLists.txt
@@ -166,6 +166,10 @@ set (utests_sources
compiler_workgroup_reduce.cpp
compiler_workgroup_scan_exclusive.cpp
compiler_workgroup_scan_inclusive.cpp
+ compiler_subgroup_broadcast.cpp
+ compiler_subgroup_reduce.cpp
+ compiler_subgroup_scan_exclusive.cpp
+ compiler_subgroup_scan_inclusive.cpp
compiler_async_stride_copy.cpp
compiler_insn_selection_min.cpp
compiler_insn_selection_max.cpp