summaryrefslogtreecommitdiff
path: root/CMakeLists.txt
diff options
context:
space:
mode:
authorBui Nguyen Quoc Thanh <49302843+thanhbnq@users.noreply.github.com>2022-05-10 10:24:14 +0700
committerGitHub <noreply@github.com>2022-05-10 10:24:14 +0700
commit7a48f750137c5bf242d55e170fdfe238dff65e13 (patch)
tree107b4c5be3e7a69a3f49ce045e49eff87bb69215 /CMakeLists.txt
parent0a1c9211af1b0d4f57ff75b4a4832140969722a1 (diff)
parentfbda66c2ed84221466914a71e49319d83ad37d22 (diff)
downloadDLT-daemon-7a48f750137c5bf242d55e170fdfe238dff65e13.tar.gz
Merge pull request #363 from alexmohr/make-console-tools-configurable
cmake: Add options to enable/disable each dlt console tool
Diffstat (limited to 'CMakeLists.txt')
-rw-r--r--CMakeLists.txt5
1 files changed, 5 insertions, 0 deletions
diff --git a/CMakeLists.txt b/CMakeLists.txt
index 8aaa403..49494af 100644
--- a/CMakeLists.txt
+++ b/CMakeLists.txt
@@ -61,6 +61,11 @@ option(WITH_DLT_ADAPTOR_UDP "Set to ON to build src/adaptor/udp binaries"
option(WITH_DLT_CONSOLE "Set to ON to build src/console binaries" ON)
option(WITH_DLT_CONSOLE_WO_CTRL "Set to ON not to build control commands under src/console" OFF)
option(WITH_DLT_CONSOLE_WO_SBTM "Set to ON not to build dlt-sortbytimestamp under src/console" OFF)
+option(WITH_DLT_CONSOLE_RECEIVE "Set to OFF to skip building dlt_receive" ON)
+option(WITH_DLT_CONSOLE_CONVERT "Set to OFF to skip building dlt_convert" ON)
+option(WITH_DLT_CONSOLE_CONTROL "Set to OFF to skip building dlt_control" ON)
+option(WITH_DLT_CONSOLE_PASSIVE_NODE_CTRL "Set to OFF to skip building dlt_passive_node_ctrl" ON)
+
option(WITH_DLT_EXAMPLES "Set to ON to build src/examples binaries" ON)
option(WITH_DLT_FILETRANSFER "Set to ON to build dlt-system with filetransfer support" OFF)
option(WITH_DLT_SYSTEM "Set to ON to build src/system binaries" OFF)