summaryrefslogtreecommitdiff
path: root/CMakeLists.txt
diff options
context:
space:
mode:
authorAlexander Mohr <alexander.m.mohr@daimler.com>2022-01-20 16:58:31 +0100
committerAlexander Mohr <alexander.m.mohr@daimler.com>2022-01-25 11:34:01 +0100
commitfbda66c2ed84221466914a71e49319d83ad37d22 (patch)
tree97277d48cff4d0076ccffc5cd75a9a08b7ce6f33 /CMakeLists.txt
parent0138c00811c86eab4ff6bff3c6528163885ade19 (diff)
downloadDLT-daemon-fbda66c2ed84221466914a71e49319d83ad37d22.tar.gz
cmake: Add options to enable/disable each dlt console tool
This commits adds several cmake options to enable or disable each console tool separately. Signed-off-by: Alexander Mohr <alexander.m.mohr@daimler.com>
Diffstat (limited to 'CMakeLists.txt')
-rw-r--r--CMakeLists.txt5
1 files changed, 5 insertions, 0 deletions
diff --git a/CMakeLists.txt b/CMakeLists.txt
index e88f886..1647f31 100644
--- a/CMakeLists.txt
+++ b/CMakeLists.txt
@@ -59,6 +59,11 @@ option(WITH_DLT_ADAPTOR "Set to ON to build src/adaptor binaries"
option(WITH_DLT_CONSOLE "Set to ON to build src/console binaries" ON)
option(WITH_DLT_CONSOLE_WO_CTRL "Set to ON not to build control commands under src/console" OFF)
option(WITH_DLT_CONSOLE_WO_SBTM "Set to ON not to build dlt-sortbytimestamp under src/console" OFF)
+option(WITH_DLT_CONSOLE_RECEIVE "Set to OFF to skip building dlt_receive" ON)
+option(WITH_DLT_CONSOLE_CONVERT "Set to OFF to skip building dlt_convert" ON)
+option(WITH_DLT_CONSOLE_CONTROL "Set to OFF to skip building dlt_control" ON)
+option(WITH_DLT_CONSOLE_PASSIVE_NODE_CTRL "Set to OFF to skip building dlt_passive_node_ctrl" ON)
+
option(WITH_DLT_EXAMPLES "Set to ON to build src/examples binaries" ON)
option(WITH_DLT_FILETRANSFER "Set to ON to build dlt-system with filetransfer support" OFF)
option(WITH_DLT_SYSTEM "Set to ON to build src/system binaries" OFF)