summaryrefslogtreecommitdiff
path: root/TAO/tests/Portable_Interceptors/ORB_Shutdown/Makefile.am
diff options
context:
space:
mode:
Diffstat (limited to 'TAO/tests/Portable_Interceptors/ORB_Shutdown/Makefile.am')
-rw-r--r--TAO/tests/Portable_Interceptors/ORB_Shutdown/Makefile.am117
1 files changed, 0 insertions, 117 deletions
diff --git a/TAO/tests/Portable_Interceptors/ORB_Shutdown/Makefile.am b/TAO/tests/Portable_Interceptors/ORB_Shutdown/Makefile.am
deleted file mode 100644
index 31f1515f381..00000000000
--- a/TAO/tests/Portable_Interceptors/ORB_Shutdown/Makefile.am
+++ /dev/null
@@ -1,117 +0,0 @@
-## Process this file with automake to create Makefile.in
-##
-## $Id$
-##
-## This file was generated by MPC. Any changes made directly to
-## this file will be lost the next time it is generated.
-##
-## MPC Command:
-## ../bin/mwc.pl -type automake -noreldefs TAO.mwc
-
-ACE_BUILDDIR = $(top_builddir)/..
-ACE_ROOT = $(top_srcdir)/..
-TAO_BUILDDIR = $(top_builddir)
-TAO_IDL = ACE_ROOT=$(ACE_ROOT) TAO_ROOT=$(TAO_ROOT) $(TAO_BUILDDIR)/TAO_IDL/tao_idl
-TAO_IDL_DEP = $(TAO_BUILDDIR)/TAO_IDL/tao_idl
-TAO_IDLFLAGS = -Wb,pre_include=ace/pre.h -Wb,post_include=ace/post.h -I$(TAO_ROOT) -I$(srcdir) -g $(ACE_BUILDDIR)/apps/gperf/src/gperf
-TAO_ROOT = $(top_srcdir)
-
-noinst_PROGRAMS =
-
-## Makefile.PI_ORB_Shutdown_Idl.am
-
-BUILT_SOURCES = \
- testC.cpp \
- testC.h \
- testC.inl \
- testS.cpp \
- testS.h \
- testS.inl
-
-CLEANFILES = \
- test-stamp \
- testC.cpp \
- testC.h \
- testC.inl \
- testS.cpp \
- testS.h \
- testS.inl
-
-testC.cpp testC.h testC.inl testS.cpp testS.h testS.inl: test-stamp
-
-test-stamp: $(srcdir)/test.idl $(TAO_IDL_DEP)
- $(TAO_IDL) $(TAO_IDLFLAGS) -Sa -St $(srcdir)/test.idl
- @touch $@
-
-noinst_HEADERS = \
- test.idl
-
-## Makefile.PI_ORB_Shutdown_Client.am
-
-if BUILD_EXCEPTIONS
-
-noinst_PROGRAMS += client
-
-client_CPPFLAGS = \
- -I$(ACE_ROOT) \
- -I$(ACE_BUILDDIR) \
- -I$(TAO_ROOT) \
- -I$(TAO_BUILDDIR)
-
-client_SOURCES = \
- client.cpp \
- testC.cpp \
- Server_ORBInitializer.h \
- Server_Request_Interceptor.h \
- test_i.h
-
-client_LDADD = \
- $(TAO_BUILDDIR)/tao/libTAO_AnyTypeCode.la \
- $(TAO_BUILDDIR)/tao/libTAO.la \
- $(ACE_BUILDDIR)/ace/libACE.la
-
-endif BUILD_EXCEPTIONS
-
-## Makefile.PI_ORB_Shutdown_Server.am
-
-if BUILD_EXCEPTIONS
-if BUILD_INTERCEPTORS
-
-noinst_PROGRAMS += server
-
-server_CPPFLAGS = \
- -I$(ACE_ROOT) \
- -I$(ACE_BUILDDIR) \
- -I$(TAO_ROOT) \
- -I$(TAO_BUILDDIR)
-
-server_SOURCES = \
- Server_ORBInitializer.cpp \
- Server_Request_Interceptor.cpp \
- server.cpp \
- testC.cpp \
- testS.cpp \
- test_i.cpp \
- Server_ORBInitializer.h \
- Server_Request_Interceptor.h \
- test_i.h
-
-server_LDADD = \
- $(TAO_BUILDDIR)/tao/libTAO_PI_Server.la \
- $(TAO_BUILDDIR)/tao/libTAO_PI.la \
- $(TAO_BUILDDIR)/tao/libTAO_CodecFactory.la \
- $(TAO_BUILDDIR)/tao/libTAO_PortableServer.la \
- $(TAO_BUILDDIR)/tao/libTAO_AnyTypeCode.la \
- $(TAO_BUILDDIR)/tao/libTAO.la \
- $(ACE_BUILDDIR)/ace/libACE.la
-
-endif BUILD_INTERCEPTORS
-endif BUILD_EXCEPTIONS
-
-## Clean up template repositories, etc.
-clean-local:
- -rm -f *~ *.bak *.rpo *.sym lib*.*_pure_* core core.*
- -rm -f gcctemp.c gcctemp so_locations *.ics
- -rm -rf cxx_repository ptrepository ti_files
- -rm -rf templateregistry ir.out
- -rm -rf ptrepository SunWS_cache Templates.DB