summaryrefslogtreecommitdiff
path: root/TAO/performance-tests/Protocols/Makefile.am
diff options
context:
space:
mode:
Diffstat (limited to 'TAO/performance-tests/Protocols/Makefile.am')
-rw-r--r--TAO/performance-tests/Protocols/Makefile.am9
1 files changed, 2 insertions, 7 deletions
diff --git a/TAO/performance-tests/Protocols/Makefile.am b/TAO/performance-tests/Protocols/Makefile.am
index 54843c6a9e7..81c6a7eadb9 100644
--- a/TAO/performance-tests/Protocols/Makefile.am
+++ b/TAO/performance-tests/Protocols/Makefile.am
@@ -13,7 +13,7 @@ ACE_ROOT = $(top_srcdir)/..
TAO_BUILDDIR = $(top_builddir)
TAO_IDL = ACE_ROOT=$(ACE_ROOT) TAO_ROOT=$(TAO_ROOT) $(TAO_BUILDDIR)/TAO_IDL/tao_idl
TAO_IDL_DEP = $(TAO_BUILDDIR)/TAO_IDL/tao_idl
-TAO_IDLFLAGS = -Wb,pre_include=ace/pre.h -Wb,post_include=ace/post.h -I$(TAO_ROOT) -I$(srcdir) -g $(ACE_BUILDDIR)/apps/gperf/src/gperf
+TAO_IDLFLAGS = -Ge 1 -Wb,pre_include=ace/pre.h -Wb,post_include=ace/post.h -I$(TAO_ROOT) -I$(srcdir) -g $(ACE_BUILDDIR)/apps/gperf/src/gperf
TAO_ROOT = $(top_srcdir)
noinst_PROGRAMS =
@@ -43,12 +43,12 @@ test-stamp: $(srcdir)/test.idl $(TAO_IDL_DEP)
$(TAO_IDL) $(TAO_IDLFLAGS) -Sa -St $(srcdir)/test.idl
@touch $@
+
noinst_HEADERS = \
test.idl
## Makefile.Protocols_Distributor.am
-if BUILD_EXCEPTIONS
if BUILD_RT_CORBA
noinst_PROGRAMS += distributor
@@ -75,11 +75,9 @@ distributor_LDADD = \
$(ACE_BUILDDIR)/ace/libACE.la
endif BUILD_RT_CORBA
-endif BUILD_EXCEPTIONS
## Makefile.Protocols_Receiver.am
-if BUILD_EXCEPTIONS
if !BUILD_ACE_FOR_TAO
noinst_PROGRAMS += receiver
@@ -102,11 +100,9 @@ receiver_LDADD = \
$(ACE_BUILDDIR)/ace/libACE.la
endif !BUILD_ACE_FOR_TAO
-endif BUILD_EXCEPTIONS
## Makefile.Protocols_Sender.am
-if BUILD_EXCEPTIONS
if BUILD_RT_CORBA
if !BUILD_ACE_FOR_TAO
@@ -133,7 +129,6 @@ sender_LDADD = \
endif !BUILD_ACE_FOR_TAO
endif BUILD_RT_CORBA
-endif BUILD_EXCEPTIONS
## Clean up template repositories, etc.
clean-local: