summaryrefslogtreecommitdiff
path: root/TAO/orbsvcs/tests/Event/Performance/Makefile.am
diff options
context:
space:
mode:
Diffstat (limited to 'TAO/orbsvcs/tests/Event/Performance/Makefile.am')
-rw-r--r--TAO/orbsvcs/tests/Event/Performance/Makefile.am50
1 files changed, 50 insertions, 0 deletions
diff --git a/TAO/orbsvcs/tests/Event/Performance/Makefile.am b/TAO/orbsvcs/tests/Event/Performance/Makefile.am
index 0da617d516c..f12a1c355ef 100644
--- a/TAO/orbsvcs/tests/Event/Performance/Makefile.am
+++ b/TAO/orbsvcs/tests/Event/Performance/Makefile.am
@@ -36,6 +36,16 @@ Connect_SOURCES = \
Connect.cpp \
Connect.h
+../lib:
+ mkdir -p ../lib
+
+
+Connect_DEPENDENCIES = \
+ ../lib
+
+Connect_LDFLAGS = \
+ -L../lib
+
Connect_LDADD = \
$(top_builddir)/orbsvcs/tests/Event/lib/libECTests.la \
$(TAO_BUILDDIR)/tao/libTAO_IORTable.la \
@@ -78,6 +88,16 @@ Inversion_SOURCES = \
Inversion.cpp \
Inversion.h
+../lib:
+ mkdir -p ../lib
+
+
+Inversion_DEPENDENCIES = \
+ ../lib
+
+Inversion_LDFLAGS = \
+ -L../lib
+
Inversion_LDADD = \
$(top_builddir)/orbsvcs/tests/Event/lib/libECTests.la \
$(TAO_BUILDDIR)/tao/libTAO_IORTable.la \
@@ -120,6 +140,16 @@ Latency_SOURCES = \
Latency.cpp \
Latency.h
+../lib:
+ mkdir -p ../lib
+
+
+Latency_DEPENDENCIES = \
+ ../lib
+
+Latency_LDFLAGS = \
+ -L../lib
+
Latency_LDADD = \
$(TAO_BUILDDIR)/tao/libTAO_Strategies.la \
$(top_builddir)/orbsvcs/tests/Event/lib/libECTests.la \
@@ -166,6 +196,16 @@ Latency_Server_SOURCES = \
Latency.h \
Throughput.h
+../lib:
+ mkdir -p ../lib
+
+
+Latency_Server_DEPENDENCIES = \
+ ../lib
+
+Latency_Server_LDFLAGS = \
+ -L../lib
+
Latency_Server_LDADD = \
$(TAO_BUILDDIR)/tao/libTAO_Strategies.la \
$(top_builddir)/orbsvcs/tests/Event/lib/libECTests.la \
@@ -209,6 +249,16 @@ Throughput_SOURCES = \
Throughput.cpp \
Throughput.h
+../lib:
+ mkdir -p ../lib
+
+
+Throughput_DEPENDENCIES = \
+ ../lib
+
+Throughput_LDFLAGS = \
+ -L../lib
+
Throughput_LDADD = \
$(top_builddir)/orbsvcs/tests/Event/lib/libECTests.la \
$(TAO_BUILDDIR)/tao/libTAO_IORTable.la \