summaryrefslogtreecommitdiff
path: root/TAO/orbsvcs/ImplRepo_Service/Makefile.am
diff options
context:
space:
mode:
Diffstat (limited to 'TAO/orbsvcs/ImplRepo_Service/Makefile.am')
-rw-r--r--TAO/orbsvcs/ImplRepo_Service/Makefile.am8
1 files changed, 8 insertions, 0 deletions
diff --git a/TAO/orbsvcs/ImplRepo_Service/Makefile.am b/TAO/orbsvcs/ImplRepo_Service/Makefile.am
index fdcda8567ac..9176e88c9cd 100644
--- a/TAO/orbsvcs/ImplRepo_Service/Makefile.am
+++ b/TAO/orbsvcs/ImplRepo_Service/Makefile.am
@@ -176,6 +176,7 @@ endif BUILD_CORBA_MESSAGING
if BUILD_ACEXML
if BUILD_CORBA_MESSAGING
+if !BUILD_ACE_FOR_TAO
if !BUILD_MINIMUM_CORBA
noinst_LTLIBRARIES += libTAO_ImR_Activator.la
@@ -202,6 +203,7 @@ noinst_HEADERS += \
activator_export.h
endif !BUILD_MINIMUM_CORBA
+endif !BUILD_ACE_FOR_TAO
endif BUILD_CORBA_MESSAGING
endif BUILD_ACEXML
@@ -209,6 +211,7 @@ endif BUILD_ACEXML
if BUILD_ACEXML
if BUILD_CORBA_MESSAGING
+if !BUILD_ACE_FOR_TAO
if !BUILD_MINIMUM_CORBA
bin_PROGRAMS += ImR_Activator
@@ -245,6 +248,7 @@ ImR_Activator_LDADD = \
$(ACE_BUILDDIR)/ace/libACE.la
endif !BUILD_MINIMUM_CORBA
+endif !BUILD_ACE_FOR_TAO
endif BUILD_CORBA_MESSAGING
endif BUILD_ACEXML
@@ -252,6 +256,7 @@ endif BUILD_ACEXML
if BUILD_ACEXML
if BUILD_CORBA_MESSAGING
+if !BUILD_ACE_FOR_TAO
if !BUILD_MINIMUM_CORBA
noinst_LTLIBRARIES += libTAO_ImR_Locator.la
@@ -297,6 +302,7 @@ noinst_HEADERS += \
utils.h
endif !BUILD_MINIMUM_CORBA
+endif !BUILD_ACE_FOR_TAO
endif BUILD_CORBA_MESSAGING
endif BUILD_ACEXML
@@ -304,6 +310,7 @@ endif BUILD_ACEXML
if BUILD_ACEXML
if BUILD_CORBA_MESSAGING
+if !BUILD_ACE_FOR_TAO
if !BUILD_MINIMUM_CORBA
bin_PROGRAMS += ImplRepo_Service
@@ -342,6 +349,7 @@ ImplRepo_Service_LDADD = \
$(ACE_BUILDDIR)/ace/libACE.la
endif !BUILD_MINIMUM_CORBA
+endif !BUILD_ACE_FOR_TAO
endif BUILD_CORBA_MESSAGING
endif BUILD_ACEXML