summaryrefslogtreecommitdiff
path: root/TAO/examples/PluggableUDP/tests/Performance/Makefile.am
diff options
context:
space:
mode:
authorjtc <jtc@ae88bc3d-4319-0410-8dbf-d08b4c9d3795>2005-10-07 21:17:33 +0000
committerjtc <jtc@ae88bc3d-4319-0410-8dbf-d08b4c9d3795>2005-10-07 21:17:33 +0000
commitf2c12d9c93a12e93e6d1a25753d640abbf353fb4 (patch)
tree3846252db64c46262fe88d395eb6ef1a588b756b /TAO/examples/PluggableUDP/tests/Performance/Makefile.am
parentaf4883ef5b4ecaad48961eac537defe53b417920 (diff)
downloadATCD-f2c12d9c93a12e93e6d1a25753d640abbf353fb4.tar.gz
ChangeLogTag: Fri Oct 7 14:03:54 2005 J.T. Conklin <jtc@acorntoolworks.com>
Diffstat (limited to 'TAO/examples/PluggableUDP/tests/Performance/Makefile.am')
-rw-r--r--TAO/examples/PluggableUDP/tests/Performance/Makefile.am5
1 files changed, 3 insertions, 2 deletions
diff --git a/TAO/examples/PluggableUDP/tests/Performance/Makefile.am b/TAO/examples/PluggableUDP/tests/Performance/Makefile.am
index 1b4def35af7..bbe0455c339 100644
--- a/TAO/examples/PluggableUDP/tests/Performance/Makefile.am
+++ b/TAO/examples/PluggableUDP/tests/Performance/Makefile.am
@@ -12,6 +12,7 @@ ACE_BUILDDIR = $(top_builddir)/..
ACE_ROOT = $(top_srcdir)/..
TAO_BUILDDIR = $(top_builddir)
TAO_IDL = ACE_ROOT=$(ACE_ROOT) TAO_ROOT=$(TAO_ROOT) $(TAO_BUILDDIR)/TAO_IDL/tao_idl
+TAO_IDL_DEP = $(TAO_BUILDDIR)/TAO/TAO_IDL/tao_idl
TAO_IDLFLAGS = -Ge 1 -Wb,pre_include=ace/pre.h -Wb,post_include=ace/post.h -I$(TAO_ROOT) -I$(srcdir) -g $(ACE_BUILDDIR)/apps/gperf/src/gperf
TAO_ROOT = $(top_srcdir)
@@ -42,7 +43,7 @@ CLEANFILES = \
UDPC.cpp UDPC.h UDPC.inl UDPS.cpp UDPS.h UDPS.inl UDPS_T.cpp UDPS_T.h UDPS_T.inl: UDP-stamp
-UDP-stamp: $(srcdir)/UDP.idl
+UDP-stamp: $(srcdir)/UDP.idl $(TAO_IDL_DEP)
$(TAO_IDL) $(TAO_IDLFLAGS) -Sd -Sp $(srcdir)/UDP.idl
@touch $@
@@ -102,7 +103,7 @@ CLEANFILES += \
UDPC.cpp UDPC.h UDPC.inl UDPS.cpp UDPS.h UDPS.inl UDPS_T.cpp UDPS_T.h UDPS_T.inl: UDP-stamp
-UDP-stamp: $(srcdir)/UDP.idl
+UDP-stamp: $(srcdir)/UDP.idl $(TAO_IDL_DEP)
$(TAO_IDL) $(TAO_IDLFLAGS) -Sd -Sp $(srcdir)/UDP.idl
@touch $@