summaryrefslogtreecommitdiff
path: root/setup.py
diff options
context:
space:
mode:
authorLauren Perry <lauren.perry@codethink.co.uk>2014-12-11 16:36:04 +0000
committerLauren Perry <lauren.perry@codethink.co.uk>2014-12-17 12:27:03 +0000
commit779fd24b8e9926e5b8cc2949589544a58abbda80 (patch)
treecbfaf9e3a173abf0c07aad0d3847fef7a23b8da2 /setup.py
parent8a2aed17cdaaf2ba20cd9f12f21f703475564406 (diff)
downloadfirehose-779fd24b8e9926e5b8cc2949589544a58abbda80.tar.gz
Add tools for installing Firehose and its dependencies
Diffstat (limited to 'setup.py')
-rw-r--r--setup.py16
1 files changed, 16 insertions, 0 deletions
diff --git a/setup.py b/setup.py
new file mode 100644
index 0000000..418f4c6
--- /dev/null
+++ b/setup.py
@@ -0,0 +1,16 @@
+from setuptools import setup
+setup(
+ name = "firehose",
+ version = "0.1",
+ packages = ["firehose", "debian"],
+ package_data={
+ "firehose":
+ ["plugin/*.py"]
+ },
+ scripts = [
+ "firehose.sh"
+ ],
+ # This is because morph won't find it as a plugin if it is
+ # installed as a .egg file
+ zip_safe = False
+)