summaryrefslogtreecommitdiff
path: root/CMakeLists.txt
diff options
context:
space:
mode:
authorChristoph J. Thompson <cjsthompson@gmail.com>2012-03-12 17:31:58 +0100
committerMark Adler <madler@alumni.caltech.edu>2012-03-12 22:15:16 -0700
commit39c7ed14ac67413ac481aa136d2606d94e24536e (patch)
treec66982d335757accc38c69441251ff2a989d5595 /CMakeLists.txt
parentc1e84b258c462a88ea0398b45515781f0c583ecb (diff)
downloadzlib-39c7ed14ac67413ac481aa136d2606d94e24536e.tar.gz
If using cmake with MSVC, add the source directory to the includes.
modified: CMakeLists.txt
Diffstat (limited to 'CMakeLists.txt')
-rw-r--r--CMakeLists.txt1
1 files changed, 1 insertions, 0 deletions
diff --git a/CMakeLists.txt b/CMakeLists.txt
index 2ee2dbc..39530f2 100644
--- a/CMakeLists.txt
+++ b/CMakeLists.txt
@@ -60,6 +60,7 @@ if(MSVC)
set(CMAKE_DEBUG_POSTFIX "d")
add_definitions(-D_CRT_SECURE_NO_DEPRECATE)
add_definitions(-D_CRT_NONSTDC_NO_DEPRECATE)
+ include_directories(${CMAKE_CURRENT_SOURCE_DIR})
endif()
if(NOT CMAKE_CURRENT_SOURCE_DIR STREQUAL CMAKE_CURRENT_BINARY_DIR)